Enter key pressed in the Awesome Bar does not open an URL sometimes

VERIFIED FIXED in Firefox 11

Status

()

defect
P3
normal
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: alexp, Assigned: alexp)

Tracking

unspecified
Firefox 12
All
Android
Points:
---
Dependency tree / graph
Bug Flags:
in-litmus +

Firefox Tracking Flags

(firefox11- verified, fennec11+)

Details

(Whiteboard: [HKB][QA+])

Attachments

(1 attachment)

Assignee

Description

8 years ago
Sometimes when an URL is edited with a hardware keyboard, a following press of the Enter key does not open the URL - nothing happens, only the focus moves to the list below.
Looks like another issue related to the focus stealing by the TabHost.
Which phone were you using? We (QA) should check to verify if another phone does this the same thing.
Assignee: nobody → blassey.bugs
Priority: -- → P3
Assignee

Comment 2

8 years ago
(In reply to Aaron Train [:aaronmt] from comment #1)
> Which phone were you using? We (QA) should check to verify if another phone
> does this the same thing.

I see this from time to time on Motorola Droid Pro and Droid 3. Don't have the exact STR though. It seems consistent on Droid Pro with Swiftkey X installed.
Assignee: blassey.bugs → alexp
Assignee

Comment 3

8 years ago
Posted patch FixSplinter Review
The fix works on Droid Pro and Droid 3.
Attachment #583373 - Flags: review?(blassey.bugs)
Attachment #583373 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/7f9d4bc442c6
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
Whiteboard: [HKB] → [HKB][fennec-aurora]
Flags: in-litmus?(nhirata.bugzilla)
Whiteboard: [HKB][fennec-aurora] → [HKB][fennec-aurora][QA+]
Assignee

Updated

8 years ago
Attachment #583373 - Flags: approval-mozilla-aurora?
Attachment #583373 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 6

8 years ago
Verified with:
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20111229 Firefox/12.0a1
Fennec/12.0a1
HTC Desire Z (Android 2.3)

Couldn't reproduce this issue, URL's are opened each time.
Status: RESOLVED → VERIFIED
tracking-fennec: --- → 11+
litmus test cases : 48287, 48289, 48288
Flags: in-litmus?(nhirata.bugzilla) → in-litmus+
You need to log in before you can comment on or make changes to this bug.