Last Comment Bug 705997 - Remove additional Java Consoles
: Remove additional Java Consoles
Status: RESOLVED FIXED
[qa?]
:
Product: Firefox
Classification: Client Software
Component: Installer (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 9
Assigned To: Robert Strong [:rstrong] (use needinfo to contact me)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-28 23:23 PST by Justin Scott [:fligtar]
Modified: 2011-12-12 11:34 PST (History)
7 users (show)
robert.strong.bugs: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
fixed


Attachments
patch rev1 (3.00 KB, patch)
2011-11-29 15:26 PST, Robert Strong [:rstrong] (use needinfo to contact me)
netzen: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Justin Scott [:fligtar] 2011-11-28 23:23:23 PST
In bug 654131, we removed a number of Java Consoles in use at the time, but several more have been added since then accounting for tens of millions of users. We should update the list again.

{CAFEEFAC-0016-0000-0027-ABCDEFFEDCBA}
{CAFEEFAC-0016-0000-0028-ABCDEFFEDCBA}
{CAFEEFAC-0016-0000-0029-ABCDEFFEDCBA}
{CAFEEFAC-0016-0000-0030-ABCDEFFEDCBA}
{CAFEEFAC-0016-0000-0031-ABCDEFFEDCBA}
{CAFEEFAC-0016-0000-0032-ABCDEFFEDCBA}
{CAFEEFAC-0017-0000-0001-ABCDEFFEDCBA}
{CAFEEFAC-0017-0000-0002-ABCDEFFEDCBA}
{CAFEEFAC-0017-0000-0003-ABCDEFFEDCBA}
{CAFEEFAC-0017-0000-0004-ABCDEFFEDCBA}

I'd like this to land on Beta or at least Aurora -- it's very low risk and will help clean up this mess without waiting months.
Comment 1 Robert Strong [:rstrong] (use needinfo to contact me) 2011-11-29 15:26:38 PST
Created attachment 577775 [details] [diff] [review]
patch rev1
Comment 2 Brian R. Bondy [:bbondy] 2011-11-29 16:00:41 PST
Comment on attachment 577775 [details] [diff] [review]
patch rev1

Looks good, verified it matches up to each of the IDs in the original post a and the NSIS logic lib code looks good in PostUpdate.
Comment 3 Robert Strong [:rstrong] (use needinfo to contact me) 2011-11-30 16:21:37 PST
Pushed to fx-team
https://hg.mozilla.org/integration/fx-team/rev/984277762e0e
Comment 4 Tim Taubert [:ttaubert] 2011-11-30 22:22:45 PST
https://hg.mozilla.org/mozilla-central/rev/984277762e0e
Comment 5 Robert Strong [:rstrong] (use needinfo to contact me) 2011-12-01 10:42:52 PST
fligtar, if you still want this on other branches please nominate and include the justification for product drivers. Thanks!
Comment 6 Justin Scott [:fligtar] 2011-12-04 20:09:10 PST
Comment on attachment 577775 [details] [diff] [review]
patch rev1

This patch removes additional Java Consoles that have surfaced since our original removal of Java Consoles a few months ago in Firefox 8. These versions account for tens of millions of users and can cause users to see incompatibility dialogs when upgrading. This is a low risk patch that just adds additional GUIDs to the list of removals on upgrade. Would like it to land sooner than Firefox 11.
Comment 7 Robert Strong [:rstrong] (use needinfo to contact me) 2011-12-04 20:14:19 PST
Specifically, the add-on compatibility dialog after upgrading since we don't report incompatible extensions located in the installation directory's extensions directory.
Comment 8 Alex Keybl [:akeybl] 2011-12-05 13:38:50 PST
Comment on attachment 577775 [details] [diff] [review]
patch rev1

[Triage Comment]
We're using a known mechanism to remove Java Consoles, so unless the GUIDs are incorrect for some reason, this is very low risk. Approving for aurora and beta. Please land asap.
Comment 9 Alex Keybl [:akeybl] 2011-12-06 11:39:01 PST
Please land ASAP to make it into today's beta.
Comment 10 Robert Strong [:rstrong] (use needinfo to contact me) 2011-12-06 13:04:45 PST
Pushed to mozilla-aurora
https://hg.mozilla.org/releases/mozilla-aurora/rev/f294d7315211

Pushed to mozilla-beta
https://hg.mozilla.org/releases/mozilla-beta/rev/75ab3bc0ea30
Comment 11 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-12-07 13:51:13 PST
Do we know what versions of Java SE installs these consoles so QA can verify the fix?
Comment 12 Justin Scott [:fligtar] 2011-12-12 11:34:42 PST
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #11)
> Do we know what versions of Java SE installs these consoles so QA can verify
> the fix?

I don't know the specific Java version numbers tied with installation; it's probably a good bet that these come with the most recent ones, as they'll usually get a couple users for a few weeks and then surge to become the most-used version all of the sudden.

Note You need to log in before you can comment on or make changes to this bug.