Closed Bug 706070 Opened 11 years ago Closed 11 years ago

Apps: Moving through the screenshots of an app by pressing arrow keys is not working on Chrome

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect, P5)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: johnny.mozbugs, Assigned: spasovski)

References

()

Details

User is logged in. Happens only on Google Chrome 15.0.874.121 m

1. Load https://apps-preview-dev.allizom.org/en-US/apps/app/rolling-stone/
2. Click on any screenshot.
3. Click on arrows >> and << to see the next and previous image.
4. On keyboard, press Arrow-Left or Arrow-Right to see the same action.

Expected Results: Pressing -> (Arrow-Right) and <- (Arrow-Left) on the keyboard should display the next and the previous screenshot.
Actual Results: Pressing those keys will jump to another window. (Is this Chrome specific???)
Assignee: nobody → cwiemeersch
OS: Windows XP → All
Hardware: x86 → All
Priority: -- → P5
Assignee: cvan → dspasovski
Target Milestone: --- → 6.3.4
Target Milestone: 6.3.4 → 6.3.5
Target Milestone: 6.3.5 → 6.3.6
Blocks: 710074
No longer blocks: 690899
Can't reproduce...someone verify this bug is still valid.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Still experiencing this problem on Google Chrome 16.0.912.63 m for Windows XP.
First time, next/prev works fine all the way to the last image and back to first image. If you are on the last screenshot, and tap Next (Arrow-Right) nothing happens, obviously. But this seems to break it, since later keyboard commands work only once or don't work at all. 
Sometimes, after this, trying to reach next/prev image via keyboard is awkward, since it will shift the focus on other window instead of keeping it in the Chrome Tab.
Try this sequence at a normal pace:
- load https://apps-preview-dev.allizom.org/en-US/apps/app/rolling-stone/
- click on first image
- on keyboard press ->,->,->,->,<-
- close image preview
- click on image
- from keyboard press ->, ->, <- (notice the second -> will not work anymore)

Screencast http://screencast.com/t/X8wLzNsFh
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
done: https://github.com/mozilla/zamboni/commit/1fb3bdf
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Verified fixed. Works great on latest Chrome and FF release.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.