Last Comment Bug 706113 - Remove null checks after constructors in VideoDocument.cpp
: Remove null checks after constructors in VideoDocument.cpp
Status: RESOLVED FIXED
[good first bug][mentor=Ms2ger]
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: [retired]
:
Mentors:
Depends on:
Blocks: deadcode
  Show dependency treegraph
 
Reported: 2011-11-29 07:37 PST by (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
Modified: 2011-12-02 03:17 PST (History)
3 users (show)
bzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (897 bytes, patch)
2011-11-30 11:09 PST, [retired]
bugs: review+
jaws: feedback+
Details | Diff | Review

Description (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-11-29 07:37:20 PST
> mozilla::dom::VideoDocument* doc = new mozilla::dom::VideoDocument();
> NS_ENSURE_TRUE(doc, NS_ERROR_OUT_OF_MEMORY);

These checks are unnecessary since we are not using |new (std::nothrow)|.

http://mxr.mozilla.org/mozilla-central/source/content/html/document/src/VideoDocument.cpp#161

http://mxr.mozilla.org/mozilla-central/source/content/html/document/src/VideoDocument.cpp#87
Comment 1 [retired] 2011-11-30 11:09:46 PST
Created attachment 578019 [details] [diff] [review]
patch
Comment 2 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-11-30 17:06:48 PST
Comment on attachment 578019 [details] [diff] [review]
patch

Looks good to me, but I can't review this. I've forwarded the review to Olli.
Comment 3 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-12-01 11:29:23 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/62df7e3891cd
Comment 4 Marco Bonardo [::mak] 2011-12-02 03:17:29 PST
https://hg.mozilla.org/mozilla-central/rev/62df7e3891cd

Note You need to log in before you can comment on or make changes to this bug.