Last Comment Bug 706348 - [IncrementalGC] "Assertion failure: static_cast<Cell *>(thing)->isMarked(),"
: [IncrementalGC] "Assertion failure: static_cast<Cell *>(thing)->isMarked(),"
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86 Mac OS X
: -- critical (vote)
: ---
Assigned To: Bill McCloskey (:billm)
:
Mentors:
: 706455 706456 (view as bug list)
Depends on:
Blocks: jsfunfuzz IncrementalGC
  Show dependency treegraph
 
Reported: 2011-11-29 20:06 PST by Gary Kwong [:gkw] [:nth10sd]
Modified: 2011-11-30 11:24 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
stack (5.01 KB, text/plain)
2011-11-29 20:06 PST, Gary Kwong [:gkw] [:nth10sd]
no flags Details

Description Gary Kwong [:gkw] [:nth10sd] 2011-11-29 20:06:02 PST
Created attachment 577839 [details]
stack

for each(z in (gczeal(4, true)));

asserts js debug shell on larch changeset 7f5adef938aa without any CLI arguments at Assertion failure: static_cast<Cell *>(thing)->isMarked(),
Comment 1 Gary Kwong [:gkw] [:nth10sd] 2011-11-30 10:51:01 PST
Bill, I'm guessing you might want to take this too :)
Comment 2 Bill McCloskey (:billm) 2011-11-30 11:19:09 PST
I broke the write barrier verifier when doing incremental GC. This checkin fixed it:
https://hg.mozilla.org/projects/larch/rev/3ac7995c0101
Comment 3 Bill McCloskey (:billm) 2011-11-30 11:21:56 PST
*** Bug 706456 has been marked as a duplicate of this bug. ***
Comment 4 Bill McCloskey (:billm) 2011-11-30 11:24:01 PST
*** Bug 706455 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.