No Save Image in message context menu.

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
MailNews: Message Display
P2
minor
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: laurel, Assigned: Mark Olson)

Tracking

Trunk
mozilla0.9
All
Other

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Using mar01 commercial trunk build

No Save Image As in message pane context menu when image selected. There is a
cruft line at the end of the context menu which might be where this is supposed
to be?  Displays as (A ), but doesn't do anything.
(Reporter)

Updated

17 years ago
QA Contact: esther → nbaca
Steps to reproduce:
1: Send yourself a message with an image in it
2: Get yer Messages
3: view message in preview pane/message window
4: right click on image, note lack of Save Image as...


Severity: normal → trivial
Priority: -- → P4
Target Milestone: --- → mozilla0.9.1
Actually, you should also notice that theres a blank item on the menu, and that
choosing it deletes the message (doh!). Opening the context menu in the message
gives these two errors on the console:

JavaScript error:
chrome://communicator/content/nsContextMenu.js line 120: srGetStrBundle is not d
efined

JavaScript error:
 line 0: contextMenu has no properties

Updated

17 years ago
Severity: trivial → minor
Priority: P4 → P3
Target Milestone: mozilla0.9.1 → mozilla0.9

Comment 3

17 years ago
resetting milestone and priority.  nominating nsbeta1, mostly for the js error.
Keywords: nsbeta1
Priority: P3 → --
Target Milestone: mozilla0.9 → ---

Comment 4

17 years ago
Menu spec has:

View Image <name> 
-------------
Copy Image --- Ctrl+C
Copy Image Location 
---------------
Save Image As... 
---------------
Image Properties

http://www.mozilla.org/mailnews/specs/threepane/MailMenus.html#Context

Comment 5

17 years ago
marking nsbeta1+
Priority: -- → P2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9
Mark broke these, and said he'll fix this soon.  Reassigning.
Assignee: sspitzer → maolson
(Assignee)

Comment 7

17 years ago
Created attachment 27348 [details] [diff] [review]
patch - keeps things working until bug 56680 is fully fixed

Comment 8

17 years ago
r=jag
sr=sspitzer
(Assignee)

Comment 10

17 years ago
Fix checked in, thanks for the quick reviews guys.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
Build 2001-03-19-12: NT4
Build 2001-03-19-11: Linux RH 6.2
Build 2001-03-19-10: Mac 9.04
Reopening

The Save Image entry is there but it states "Save Image
(INBOX%3E53024?part=1.2&hackID=1)..."

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

17 years ago
While the problem manifests itself in the same menu item, it is a different/new
bug.  Bug 70655 and this should both remain fixed, and a new bug should be
opened for the fact that the mailnews code cannot get the original image filename.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
Verified Fixed.

Note: The problem with the menu item name is logged in bug# 63225.
Status: RESOLVED → VERIFIED

Comment 14

17 years ago
Looks like this issue or something v. similar is re-occuring in US build 
2001-07-24-18-0.9.2. Right click on mail sidebar panel, to produce context menu. 
The 'Save Image' label does not appear, only an extraneous hotkey (A).
This is related to German bugscape no. 6837.

Comment 15

17 years ago
Created attachment 43772 [details]
See attached screenhot
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.