Last Comment Bug 707593 - Clean up makefile generation in js/src configure
: Clean up makefile generation in js/src configure
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Ed Morley [:emorley]
:
Mentors:
: 707418 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-04 18:33 PST by Ed Morley [:emorley]
Modified: 2011-12-09 06:56 PST (History)
3 users (show)
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.63 KB, patch)
2011-12-04 18:39 PST, Ed Morley [:emorley]
no flags Details | Diff | Splinter Review
Patch v2 (1.63 KB, patch)
2011-12-05 18:41 PST, Ed Morley [:emorley]
ted: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-12-04 18:33:52 PST
Similar to the work done in bug 696498 but for js/src configure.

* js/src/lirasm/Makefile.in now longer exists in the tree, so should be removed from configure, since it was causing: "can't read <topsrcdir>/js/src/lirasm/Makefile.in: No such file or directory"
* js/src/analysis-tests/Makefile is missing from configure, so should be added.
* Several of the existing entries should only be generated conditionally, so add conditionals where needed.
Comment 1 Ed Morley [:emorley] 2011-12-04 18:39:58 PST
Created attachment 578968 [details] [diff] [review]
Patch v1
Comment 2 Ed Morley [:emorley] 2011-12-05 18:41:36 PST
Created attachment 579189 [details] [diff] [review]
Patch v2

As v1 except uses test rather than (the IMO more readable) [ EXPR ] since otherwise autoconf eats the brackets.
Comment 4 Takanori MATSUURA 2011-12-09 05:39:47 PST
*** Bug 707418 has been marked as a duplicate of this bug. ***
Comment 5 Ed Morley [:emorley] 2011-12-09 06:56:25 PST
https://hg.mozilla.org/mozilla-central/rev/19d325115037

Note You need to log in before you can comment on or make changes to this bug.