Closed Bug 707683 Opened 8 years ago Closed 8 years ago

java.lang.IllegalArgumentException: View not attached to window manager (in crashreporter)

Categories

(Firefox for Android :: General, defect, P4, critical)

ARM
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox11 --- affected
firefox12 --- affected

People

(Reporter: aaronmt, Unassigned)

Details

(Keywords: crash, reproducible, topcrash, Whiteboard: [native-crash])

Crash Data

After bug 707682's crash, restarting the browser through the crash-reporter yields:


I/ActivityManager( 2385): Starting: Intent { flg=0x40010000 cmp=org.mozilla.fennec/org.mozilla.gecko.AwesomeBar (has extras) } from pid 3010
D/GeckoAwesomeBar( 3010): creating awesomebar
D/GeckoAwesomeBarTabs( 3010): Creating AwesomeBarTabs
D/GeckoAwesomeBarTabs( 3010): Creating All Pages tab
D/GeckoAwesomeBarTabs( 3010): Creating Bookmarks tab
D/GeckoAwesomeBarTabs( 3010): Creating History tab
I/dalvikvm( 2385): Jit: resizing JitTable from 4096 to 8192
I/ActivityManager( 2385): Displayed org.mozilla.fennec/org.mozilla.gecko.AwesomeBar: +131ms
I/GeckoApp( 3010): stop
E/CursorWindow( 2883): need to grow: mSize = 1048576, size = 65019, freeSpace() = 29460, numRows = 53
E/CursorWindow( 2883): not growing since there are already 53 row(s), max size 1048576
E/Cursor  ( 2883): Failed allocating 65019 bytes for blob at 52,9
D/Cursor  ( 2883): finish_program_and_get_row_count row 6
E/GeckoApp( 3010): top level exception
E/GeckoApp( 3010): java.lang.IllegalArgumentException: View not attached to window manager
E/GeckoApp( 3010): 	at android.view.WindowManagerImpl.findViewLocked(WindowManagerImpl.java:355)
E/GeckoApp( 3010): 	at android.view.WindowManagerImpl.removeView(WindowManagerImpl.java:200)
E/GeckoApp( 3010): 	at android.view.Window$LocalWindowManager.removeView(Window.java:432)
E/GeckoApp( 3010): 	at android.app.Dialog.dismissDialog(Dialog.java:278)
E/GeckoApp( 3010): 	at android.app.Dialog.access$000(Dialog.java:71)
E/GeckoApp( 3010): 	at android.app.Dialog$1.run(Dialog.java:111)
E/GeckoApp( 3010): 	at android.app.Dialog.dismiss(Dialog.java:268)
E/GeckoApp( 3010): 	at org.mozilla.fennec.CrashReporter.finish(CrashReporter.java:124)
E/GeckoApp( 3010): 	at org.mozilla.fennec.CrashReporter$1.run(CrashReporter.java:115)
E/GeckoApp( 3010): 	at android.os.Handler.handleCallback(Handler.java:587)
E/GeckoApp( 3010): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/GeckoApp( 3010): 	at android.os.Looper.loop(Looper.java:130)
E/GeckoApp( 3010): 	at org.mozilla.gecko.GeckoApp$26.run(GeckoApp.java:1342)
E/GeckoApp( 3010): 	at android.os.Handler.handleCallback(Handler.java:587)
E/GeckoApp( 3010): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/GeckoApp( 3010): 	at android.os.Looper.loop(Looper.java:130)
E/GeckoApp( 3010): 	at android.app.ActivityThread.main(ActivityThread.java:3683)
E/GeckoApp( 3010): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/GeckoApp( 3010): 	at java.lang.reflect.Method.invoke(Method.java:507)
E/GeckoApp( 3010): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:839)
E/GeckoApp( 3010): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:597)
E/GeckoApp( 3010): 	at dalvik.system.NativeStart.main(Native Method)
D/Zygote  ( 2378): Process 3010 exited cleanly (1)
I/ActivityManager( 2385): Process org.mozilla.fennec (pid 3010) has died.
I/WindowManager( 2385): WIN DEATH: Window{406f3cd8 org.mozilla.fennec/org.mozilla.fennec.App paused=false}
I/WindowManager( 2385): WIN DEATH: Window{40882280 org.mozilla.fennec/org.mozilla.gecko.AwesomeBar paused=false}

STR:

1. Crash. In the crash-reporter, restart the browser.

--
Samsung Galaxy SII (Android 2.3.4)
20111205040214
http://hg.mozilla.org/projects/birch/rev/85e665cc4a97
Assignee: nobody → doug.turner
Priority: -- → P4
i am not working on these right now.  resetting assignee.
Assignee: doug.turner → nobody
[@ mozalloc_abort | __swrite | dexDataMapAlloc ]  is a generic crash for Java crashes.
Crash Signature: [@ mozalloc_abort | pthread_mutex_unlock ] → [@ mozalloc_abort | pthread_mutex_unlock ] [@ mozalloc_abort | __swrite | dexDataMapAlloc ]
Keywords: topcrash
Summary: java.lang.IllegalArgumentException: View not attached to window manager → java.lang.IllegalArgumentException: View not attached to window manager (in crashreporter)
494 count of crashes of this type for : 
'Android, Model: 'GT-I9100', Product: 'GT-I9100', Manufacturer: 'samsung', Hardware: 'smdkc210'' during from Dec. 20th (switch over from Nightly to Aurora)

a290755e-3e6a-480c-8fac-27cd82111223
1e20756a-a7d5-4f5c-b228-307472111225
9e17d20a-adbc-4dce-baa9-6ea212111225
d7fd7af5-9b79-41b6-8ae2-2178a2111225
a115aa56-02da-45b5-9528-059812111225
8a6d739c-9b75-41c7-8191-1affd2111225
7e235ac3-6200-4c39-b4fd-b98022111225
387758b5-cdcb-4bae-b450-0c9272111224
f974429d-9cae-4787-ae25-68fa22111224
8de1108d-2d6c-43d9-af9d-4757e2111223
1d8826a0-2a34-42f0-8e7d-539542111223
243108e7-c6b9-46d9-8048-26c8c2111224

85 Crashes on AdapterDescription: 'Android, Model: 'HTC Desire', Product: 'htc_bravo', Manufacturer: 'HTC', Hardware: 'bravo''.


Also occurs in Aurora: 

102 crashes : 
AdapterDescription: 'Android, Model: 'GT-P7510', Product: 'GT-P7510', Manufacturer: 'samsung', Hardware: 'p3''.

EGL? EGL+
AdapterVendorID: p3, AdapterDeviceID: GT-P7510.
AdapterDescription: 'Android, Model: 'GT-P7510', Product: 'GT-P7510', Manufacturer: 'samsung', Hardware: 'p3''.
java.lang.IllegalArgumentException: View not attached to window manager
	at android.view.WindowManagerImpl.findViewLocked(WindowManagerImpl.java:373)
	at android.view.WindowManagerImpl.removeView(WindowManagerImpl.java:204)
	at android.view.Window$LocalWindowManager.removeView(Window.java:534)
	at android.app.Dialog.dismissDialog(Dialog.java:306)
	at android.app.Dialog.access$000(Dialog.java:73)
	at android.app.Dialog$1.run(Dialog.java:110)
	at android.app.Dialog.dismiss(Dialog.java:296)
	at org.mozilla.fennec_aurora.CrashReporter.finish(CrashReporter.java:124)
	at org.mozilla.fennec_aurora.CrashReporter$1.run(CrashReporter.java:115)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:132)
	at org.mozilla.gecko.GeckoApp$3

85 crashes on AdapterDescription: 'Imagination Technologies, Model: 'GT-I9000', Product: 'GT-I9000', Manufacturer: 'samsung', Hardware: 'herring''.

60 crashes on AdapterVendorID: supersonic, AdapterDeviceID: PC36100.
AdapterDescription: 'Android, Model: 'PC36100', Product: 'htc_supersonic', Manufacturer: 'HTC', Hardware: 'supersonic''.

59 crashes on AdapterDescription: 'Android, Model: 'Desire HD', Product: 'htc_ace', Manufacturer: 'HTC', Hardware: 'spade''.

59 crashes on AdapterDescription: 'Android, Model: 'SPH-D710', Product: 'SPH-D710', Manufacturer: 'samsung', Hardware: 'smdkc210''.

51 crashes on AdapterDescription: 'Android, Model: 'HTC Desire HD A9191', Product: 'htc_ace', Manufacturer: 'HTC', Hardware: 'spade''.

45 crashes on AdapterDescription: 'Android, Model: 'HTC Desire S', Product: 'htc_saga', Manufacturer: 'HTC', Hardware: 'saga''.

24 crashes on AdapterDescription: 'Android, Model: 'ADR6400L', Product: 'htc_mecha', Manufacturer: 'HTC', Hardware: 'mecha''.

24 crashes on AdapterDescription: 'Android, Model: 'DROID BIONIC', Product: 'targa_vzw', Manufacturer: 'motorola', Hardware: 'mapphone_cdma''.

23 crashes on AdapterDescription: 'Android, Model: 'HTC_Amaze_4G', Product: 'htc_ruby', Manufacturer: 'HTC', Hardware: 'ruby''.

23 crashes on AdapterDescription: 'Android, Model: 'ADR6300', Product: 'inc', Manufacturer: 'HTC', Hardware: 'inc''.

22 crashes on AdapterDescription: 'Android, Model: 'SAMSUNG-SGH-I777', Product: 'SGH-I777', Manufacturer: 'samsung', Hardware: 'smdkc210''.

20 crashes on AdapterDescription: 'Android, Model: 'MB855', Product: 'moto_sunfire', Manufacturer: 'Motorola', Hardware: 'sunfire''.

18 crashes on AdapterDescription: 'Android, Model: 'X10i', Product: 'X10i_1233-7025', Manufacturer: 'Sony Ericsson', Hardware: 'es209ra''.

17 crashes on AdapterDescription: 'Android, Model: 'Acer Iconia A500', Product: 'full_a500', Manufacturer: 'unknown', Hardware: 'ventana''.

13 crashes on AdapterDescription: 'Android, Model: 'LG-P925', Product: 'lge_Cosmopolitan', Manufacturer: 'LGE', Hardware: 'omap4430''.

12 crashes on AdapterDescription: 'Android, Model: 'Sensation', Product: 'htc_pyramid', Manufacturer: 'HTC', Hardware: 'pyramid''.

12 crashes on AdapterDescription: 'NVIDIA, Model: 'Transformer Prime TF201', Product: 'US_epad', Manufacturer: 'asus', Hardware: 'cardhu''.

11 crashes on AdapterDescription: 'Android, Model: 'BNTV250', Product: 'NOOKTablet', Manufacturer: 'Barnes&Noble', Hardware: 'omap4430''.

11 crashes on AdapterDescription: 'Android, Model: 'GTablet-TnT-Lite', Product: 'harmony', Manufacturer: 'malata', Hardware: 'nvidia''.

10 crashes on AdapterDescription: 'Android, Model: 'Motorola Triumph', Product: 'triumph', Manufacturer: 'Motorola', Hardware: 'triumph''.

10 crashes on AdapterDescription: 'Android, Model: 'SO-01C', Product: 'SO-01C_1246-7916', Manufacturer: 'Sony Ericsson', Hardware: 'es209ra''.

10 crashes on AdapterDescription: 'Android, Model: 'SGH-T959', Product: 'SGH-T959', Manufacturer: 'Samsung', Hardware: 'aries''.

9 crashes on AdapterDescription: 'Android, Model: 'XT910', Product: 'XT910_RTDACH', Manufacturer: 'motorola', Hardware: 'mapphone_cdma''.

9 crashes on AdapterDescription: 'Android, Model: 'ME811', Product: 'cdma_shadow', Manufacturer: 'motorola', Hardware: 'mapphone_cdma''.

9 crashes on AdapterDescription: 'Android, Model: 'GT-I9003', Product: 'GT-I9003', Manufacturer: 'samsung', Hardware: 'latona''.

9 crashes on AdapterDescription: 'Imagination Technologies, Model: 'SGH-T849', Product: 'SGH-T849', Manufacturer: 'samsung', Hardware: 'GT-P1000''.

8 crashes on AdapterDescription: 'Android, Model: '001HT', Product: 'htc_ace', Manufacturer: 'HTC', Hardware: 'spade''.

7 Crashes on AdapterDescription: 'Imagination Technologies, Model: 'GT-I9000M', Product: 'GT-I9000M', Manufacturer: 'samsung', Hardware: 'herring''.

6 crashes on AdapterDescription: 'Android, Model: 'gTablet', Product: 'Flashback', Manufacturer: 'ViewSonic', Hardware: 'nvidia''.

6 crashes on AdapterDescription: 'Android, Model: 'MB525', Product: 'MB525_RTCEE', Manufacturer: 'motorola', Hardware: 'jordan_umts''.

5 crashes on AdapterDescription: 'Android, Model: 'IS11S', Product: 'IS11S_1248-2614', Manufacturer: 'Sony Ericsson', Hardware: 'semc''.

4 crashes on AdapterDescription: 'Android, Model: 'Full Android on Wingray', Product: 'full_wingray', Manufacturer: 'unknown', Hardware: 'stingray''.

4 crashes on AdapterDescription: 'Android, Model: 'LG-V909', Product: 'lge_startablet', Manufacturer: 'LGE', Hardware: 'startablet''.

4 crashes on AdapterDescription: 'Android, Model: 'HTC Inspire 4G', Product: 'libra_ace', Manufacturer: 'HTC', Hardware: 'spade''.

4 crashes on AdapterDescription: 'Imagination Technologies, Model: 'UTV210', Product: 'generic_utv210', Manufacturer: 'Urbetter', Hardware: 'smdkv210''.

4 crashes on AdapterDescription: 'Android, Model: 'LG-P920', Product: 'cosmopolitan', Manufacturer: 'LGE', Hardware: 'omap4430''.

4 crashes on AdapterDescription: 'Android, Model: 'A101IT', Product: 'Archos 101 Internet Tablet', Manufacturer: 'archos', Hardware: 'archos''.

3 crashes on AdapterDescription: 'Android, Model: 'MID', Product: 'MID', Manufacturer: 'VIMICRO', Hardware: 'vimicro''.

3 crashes on AdapterDescription: 'Android, Model: 'HTC EVO 3D X515a', Product: 'htc_shooteru', Manufacturer: 'HTC', Hardware: 'shooteru''.

3 crashes on AdapterDescription: 'Android, Model: 'A501', Product: 'picasso3g_generic1', Manufacturer: 'Acer', Hardware: 'picasso''.

3 crashes on AdapterDescription: 'Android, Model: 'Milestone X', Product: 'retail_us', Manufacturer: 'motorola', Hardware: 'mapphone_cdma''.

3 crashes on AdapterDescription: 'Android, Model: 'Transformer Prime TF201', Product: 'US_epad', Manufacturer: 'asus', Hardware: 'cardhu''.

3 crashes on AdapterDescription: 'Android, Model: 'SK', Product: 'b602ref', Manufacturer: 'SK300A', Hardware: 'amlogic''.

2 crashes on unknown harware

2 crashes on AdapterDescription: 'Android, Model: 'ZiiO7', Product: 'zii_lushan', Manufacturer: 'Creative Technology Ltd', Hardware: 'ziilabs''.

2 crashes on AdapterDescription: 'Android, Model: 'HTC Incredible S', Product: 'htc_vivo', Manufacturer: 'HTC', Hardware: 'vivo''.

2 crashes on AdapterDescription: 'Android, Model: 'Dell Venue', Product: 'venue', Manufacturer: 'Dell Inc.', Hardware: 'venue''.

2 crashes on AdapterDescription: 'Android, Model: '97FC', Product: 'crane_evb', Manufacturer: 'unknown', Hardware: 'sun4i''.

2 crashes on AdapterDescription: 'Android, Model: '001DL', Product: 'streak', Manufacturer: 'Dell Inc', Hardware: 'streak''.

2 crashes on AdapterDescription: 'Imagination Technologies, Model: 'CFW-MID8024', Product: 'full_smdkv210', Manufacturer: 'unknown', Hardware: 'smdkv210''.

2 crashes on AdapterDescription: 'Android, Model: 'Liquid', Product: 'Liquid', Manufacturer: 'Acer', Hardware: 'salsa''.

2 crashes on AdapterDescription: 'Android, Model: 'CUBE U9GT 2', Product: 'rk29sdk', Manufacturer: 'unknown', Hardware: 'rk29board''.

2 crashes on AdapterDescription: 'Android, Model: 'AN10G2', Product: 'rk29sdk', Manufacturer: 'unknown', Hardware: 'rk29board''.

2 crashes on AdapterDescription: 'Android, Model: 'IS06', Product: 'PTI06', Manufacturer: 'PANTECH', Hardware: 'qcom''.

2 crashes on AdapterDescription: 'Android, Model: 'HTC Pyramid', Product: 'htc_pyramid', Manufacturer: 'HTC', Hardware: 'pyramid''.

2 crashes on AdapterDescription: 'Android, Model: 'ViewPad 10s', Product: 'harmony', Manufacturer: 'nvidia', Hardware: 'nvidia''.

2 crashes on AdapterDescription: 'Android, Model: 'SN10T1', Product: 'harmony', Manufacturer: 'malata', Hardware: 'nvidia''.

2 crashes on AdapterDescription: 'Android, Model: 'Flashback 8.1', Product: 'Hannspad', Manufacturer: 'nvidia', Hardware: 'nvidia''.

2 crashes on AdapterDescription: 'Android, Model: 'Incredible', Product: 'inc', Manufacturer: 'HTC', Hardware: 'inc''.

2 crashes on AdapterDescription: 'Android, Model: 'HTC_Flyer_P512_NA', Product: 'htc_flyer', Manufacturer: 'HTC', Hardware: 'flyer''.

2 crashes on AdapterDescription: 'Android, Model: 'SGH-I997', Product: 'SGH-I997', Manufacturer: 'samsung', Hardware: 'aries''.

1 crash on AdapterVendorID: tenderloin, AdapterDeviceID: SGH-T989.
AdapterDescription: 'Android, Model: 'SGH-T989', Product: 'SGH-T989', 

1 crash on AdapterDescription: 'Android, Model: 'LG-P993', Product: 'lge_star', Manufacturer: 'lge', Hardware: 'tegra''.

1 crash on AdapterDescription: 'Android, Model: 'ATP7526', Product: 'rk29sdk', Manufacturer: 'unknown', Hardware: 'rk29board''.

1 crash on AdapterDescription: 'Android, Model: 'UPC300-2.2', Product: 'harmony', Manufacturer: 'malata', Hardware: 'nvidia''.

1 crash on AdapterDescription: 'Imagination Technologies, Model: 'GT-P1000N', Product: 'GT-P1000N', Manufacturer: 'samsung', Hardware: 'GT-P1000N''.

1 crash on AdapterDescription: 'Android, Model: 'GT8220', Product: 'tm809', Manufacturer: 'ainol', Hardware: 'amlogic''.
I cannot reproduce this issue on Fx11 or Fx12. Also bug 707682 from comment #0 cannot be reproduced anymore (because of it, this crash occurs).

I will mark it as WFM. Reopen it if this crash occurs again.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.