Average Daily Users is 50% too small & 10 days old; not updating

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: firefox.add.on, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0.1) Gecko/20100101 Firefox/8.0.1
Build ID: 20111120135848

Steps to reproduce:

I look at the number of "Users" shown on the public add-on page of Thumbnail Zoom Plus, https://addons.mozilla.org/en-US/firefox/addon/thumbnail-zoom-plus/ .  Or I look at the number of "Average Daily Users" shown on the add-ons's Statistics page https://addons.mozilla.org/en-US/firefox/addon/thumbnail-zoom-plus/statistics/?last=30 .

I compare that with the graph or table of "Daily Users, Last 30 Days" on the stats page.


Actual results:

Today (2011-12-06) I see only 4,010 "Average Daily Users", but the graph shows that on the last day reported (2011-12-05) there were 8375 daily users, and the graph has been greater than 4010 for about 10 days.  The number 4010 also has not changed in several days.

The "average in last 7 days" is also being computed including a "0" value for Dec. 6, which lowers the "average in last 7 days".

I see:

4,010 Average Daily Users 
6,331 average in last 7 days 

Daily Users by Date
Tue, Dec 6, 2011	0
Mon, Dec 5, 2011	8,375
Sun, Dec 4, 2011	7,823
Sat, Dec 3, 2011	7,836
Fri, Dec 2, 2011	        7,423
Thu, Dec 1, 2011	6,919
Wed, Nov 30, 2011	5,939
Tue, Nov 29, 2011	5,496
Mon, Nov 28, 2011	4,485
Sun, Nov 27, 2011	3,804




Expected results:

1. The count for Tue Dec 6 should not be 0, or if it is (because data isn't available) that shouldn't be one of the values averaged to produce the "average in last 7 days".  So the "average in last 7 days" should be (8375+7823+7836+7423+6919+5939+5496)/7 = 7116, not 6331.

2. I expect "Average Daily Users" and "Users" on the main add-on's page to update daily, and for its value to be at least as large as "average in the last 7 days" (7116).

Should correct "Users" on the user-facing main add-on page is important since users evaluate a plug-in partly by its number of users.
We had a major network outage around Dec 5 and 6th which made the AMO site inaccessible for most of our users. http://status.mozilla.com/11627/141985/addons.mozilla.org  I don't think there's much we can do but it should sort itself out now that we're back.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.