Closed Bug 708311 Opened 11 years ago Closed 10 years ago

Don't allow developers to deny a refund they have previously granted

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: krupa.mozbugs, Assigned: ashort)

References

()

Details

Attachments

(1 file)

Attached image screenshot
steps to reproduce:
1. Request refund for one of the apps you bought. For example: https://apps-preview-dev.allizom.org/en-US/apps/app/marble-run-4/
2. As the developer of that app, check your email. Click on the link in the email to grant refund.
3. Decline refund
4. Click the link in the email again.
5. Grant refund.
6. Repeat steps #3.

expected behavior:
Once the developer has granted refund, they shouldn't be able to decline it.

actual behavior:
Developer can hit "Decline refund" multiple times without generating any errors.
Once developers do something on that link, the link should be dead
Priority: -- → P2
Blocks: 710074
No longer blocks: 690899
Target Milestone: --- → 6.3.9
It looks like https://bugzilla.mozilla.org/show_bug.cgi?id=702981 will make this a lot simpler to implement.
Depends on: 702981
Target Milestone: 6.3.9 → 6.4.1
Target Milestone: 6.4.1 → 6.4.2
https://github.com/mozilla/zamboni/commit/e625050dcdfbf62711827cfc34874299aede0ac5
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.