Problems creating New Folder using Manage Bookmarks

VERIFIED DUPLICATE of bug 68542

Status

--
blocker
VERIFIED DUPLICATE of bug 68542
18 years ago
14 years ago

People

(Reporter: graham.knap, Assigned: bugs)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
BuildID: 2001030205 (and also 0.8) on Win95
BuildID: 2001022808 (and also 0.8) on Linux

User Interface issue in all cases; Failure to create the new folder in some
cases. (Explanation follows.)

Reproducible: Always
Steps to Reproduce:
o click Bookmarks | Manage Bookmarks
o the bookmark manager opens
o create a new folder (using any of the 3 available methods: New Folder button;
RightClick on "Bookmarks For..." | New Folder; File | New Folder )

Actual Results:  There are two cases to consider here:

1. the user profile is new and the bookmark file is freshly auto-created
2. there are a significant number of existing bookmarks, some of which were
imported from netscape 4.x bookmark files (in my case the bookmarks.html file is
61kb)

In both cases:

-> Problem #1: the items in the bookmark manager suddenly become
spaced apart vertically.

In the second case ONLY:

-> Problem #2: the new folder is often created off-screen, and the
user must scroll to the bottom of the list manually to find it
-> Problem #3: the new folder isn't created properly (or more likely, not at
all). This diagnosis is based on:
a) The name reverts back to "New Folder" immediately after initially naming it.
b) I can't perform any actions on the newly created folder such as renaming,
deleting.
c) Moving a bookmark into the new folder crashes Mozilla.
d) The new folder does not appear in the Bookmarks menu, ever.

Note that creating a subfolder (rather than a top level folder) results in
slightly different behaviour; I'm having some trouble encapsulating exactly what
happens under exactly what conditions because there are so many possibilities,
and I don't know how your code works :-P  ... but I'm doing the best I can...

Expected Results:  
1) The spacing of the items should not change
2) It would be really nice if Mozilla could automatically scroll to the new
bookmark... but that isn't critical I suppose
3) The folder needs to actually be created ...

I am setting "blocker" severity because this is a _major_ loss of functionality
for me, and can cause crashes.

Thanks for all your hard work -- Mozilla rocks!

Comment 1

18 years ago
First let me say thanks for creating such a good and detailed bug report.
However all those issues are already filed and there is a patch in the review
process. You can view the tracking bug for all the bugs in the bookmarks manager
(bug 68550). The particular issues you describe : 
1) Row spacing is increased : bug 67798.
2) Folders created off-screen and being corrupted : bug 68537, 68539, 68542
(dependant on each other, bug 68542 has the patch attached).
All those issues are actively being worked on.
Thank you for reporting bugs about Mozilla, keep up the good work!
Marking as dup of bug 68542 as a random pick.

*** This bug has been marked as a duplicate of 68542 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.