Last Comment Bug 708379 - Haptic buzz when tapping on clickable elements
: Haptic buzz when tapping on clickable elements
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
P3 normal (vote)
: ---
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on: 709048 712772
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-07 12:39 PST by Johnathan Nightingale [:johnath]
Modified: 2016-07-29 14:21 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
WIP (1.68 KB, patch)
2011-12-08 07:09 PST, Mark Finkle (:mfinkle) (use needinfo?)
no flags Details | Diff | Splinter Review
patch (4.86 KB, patch)
2011-12-08 09:01 PST, Mark Finkle (:mfinkle) (use needinfo?)
blassey.bugs: review+
Details | Diff | Splinter Review

Description User image Johnathan Nightingale [:johnath] 2011-12-07 12:39:18 PST
<johnath> madhava: should we use haptics on link clicks, or is that a terrible, terrible idea?
<madhava> johnath: not against it
<johnath> madhava: I'll put it in a bug
<chofmann> johnath: that would solve my feedback problem, not understanding if my link click actually happened...

I suspect it's cheap, maybe worth experimenting with having a haptic buzz triggered by link navigations, to make them feel a little more prominent?

Not sure where haptics would land, cc'ng some people who will know, though.
Comment 1 User image Brad Lassey [:blassey] (use needinfo?) 2011-12-07 15:57:12 PST
https://mxr.mozilla.org/mozilla-central/source/xpcom/system/nsIHapticFeedback.idl#54
Comment 2 User image Alex Keybl [:akeybl] 2011-12-08 00:06:50 PST
dupe of bug 595441? or would we track for native separately?

by the way, I love this idea.
Comment 3 User image Mark Finkle (:mfinkle) (use needinfo?) 2011-12-08 07:09:06 PST
Created attachment 580035 [details] [diff] [review]
WIP

This should work, but isn't. The method is getting called when we tap links and buttons in web content. Yes, I have haptic feedback "on" in settings.
Comment 4 User image Mark Finkle (:mfinkle) (use needinfo?) 2011-12-08 09:01:51 PST
Created attachment 580064 [details] [diff] [review]
patch

This patch adds support for "performHapticFeedback" back into GeckoAppShell. It also limits the haptic feedback to "clickable" elements.
Comment 5 User image Mark Finkle (:mfinkle) (use needinfo?) 2011-12-08 12:45:27 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/b4293d6a23ff
Comment 6 User image Ed Morley [:emorley] 2011-12-09 06:55:54 PST
https://hg.mozilla.org/mozilla-central/rev/b4293d6a23ff
Comment 7 User image Johnathan Nightingale [:johnath] 2011-12-11 12:28:05 PST
I um... *really* like this.

Asa maybe disagrees, or maybe is seeing more than the expected quantity of haptics? ( https://twitter.com/#!/asadotzler/status/145926037845458945 )

Asa - are you disliking the feature as-designed, or do you have a new bug for us?
Comment 8 User image Aaron Train [:aaronmt] 2011-12-11 12:38:12 PST
(In reply to Johnathan Nightingale [:johnath] from comment #7)
> I um... *really* like this.
> 
> Asa maybe disagrees, or maybe is seeing more than the expected quantity of
> haptics? ( https://twitter.com/#!/asadotzler/status/145926037845458945 )
> 
> Asa - are you disliking the feature as-designed, or do you have a new bug
> for us?

bug 709048
Comment 9 User image Asa Dotzler [:asa] 2011-12-11 12:45:01 PST
I am seeing haptic buzz every time I touch the screen. I think that's too much. On link clicks or form button presses, etc. I think the buzz is nice. On scrolling and panning and other actions, it feels like way too much.
Comment 10 User image Matt Brubeck (:mbrubeck) 2011-12-12 14:01:09 PST
(In reply to Asa Dotzler [:asa] from comment #9)
> I am seeing haptic buzz every time I touch the screen. I think that's too
> much. On link clicks or form button presses, etc. I think the buzz is nice.
> On scrolling and panning and other actions, it feels like way too much.

That should be fixed by bug 709048.

Note You need to log in before you can comment on or make changes to this bug.