Closed Bug 709048 Opened 8 years ago Closed 8 years ago

Over usage of haptic buzz

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: aaronmt, Assigned: mfinkle)

References

Details

(Whiteboard: [qa^])

Attachments

(1 file)

A haptic buzz is generated on finger contact with the screen just by scrolling. It's a bit overkill.

--
Samsung Nexus S (Android 2.3.6)
20111209040309
http://hg.mozilla.org/integration/mozilla-inbound/rev/947f145ec0e7
Duplicate of this bug: 709500
Seems like we need a better way of knowing when to tap is a "tap" and not a "finger down, maybe tapping or maybe dragging"
Attached patch patchSplinter Review
OK. I found that tapHighlight gets called even if your touch does not lead to a tap. We do this for "fast" feedback on finger-down. Good for visual, but bad for haptic.

This patch move the haptic call to when we actually send a "click"
Assignee: nobody → mark.finkle
Attachment #580720 - Flags: review?(mbrubeck)
Attachment #580720 - Flags: review?(mbrubeck) → review+
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/1ce022be38d4
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Verified fixed on: 
Nightly 13.0a1(2012-03-04)
Device: Samsung Galaxy S2
OS: Android 2.3.4
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.