Charset name prefixes 8-bit characters in window title

RESOLVED DUPLICATE of bug 150131

Status

()

Core
Internationalization
P4
minor
RESOLVED DUPLICATE of bug 150131
18 years ago
12 years ago

People

(Reporter: Heikki Kantola, Assigned: smontagu)

Tracking

({intl})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
When there's 8-bit (ISO Latin 1) characters in document title element, these are
shown in Mozilla window title with ugly string "%/ISO-8859-15" prefixing the
actual character. That character set code is propably originating from GNU Libc
2.2.x's Finnish locale (I've LC_CTYPE set to "fi_FI").

Comment 1

18 years ago
updating component
Assignee: asa → nhotta
Status: UNCONFIRMED → NEW
Component: Browser-General → Internationalization
Ever confirmed: true
QA Contact: doronr → andreasb

Comment 2

18 years ago
Could you specify the URL which has this problem?
(Reporter)

Comment 3

18 years ago
For fine, short example of page with 8-bit characters on title, see
<URL:http://http://www.ling.helsinki.fi/kieliteknologia/kurssit/2000s/ctl310-mt/>
It isn't same page as I took pic of, but demonstrates same behaviour as well.

Comment 4

18 years ago
I don't see the problem using today's Linux build.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
Works for me, please try again with the latest build.

Comment 6

18 years ago
I also can't reproduce it using Linux build 2001031308.  Marking as verified for
now.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

18 years ago
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

18 years ago
Still there with 0.8.1/2001-03-26.

This in on unstable branch of Debian GNU/Linux with following locale affecting
packages:

libc6          2.2.2-4        GNU C Library: Shared libraries and Timezone
locales        2.2.2-4        GNU C Library: National Language (locale) data

Updated

18 years ago
Assignee: nhotta → bstell
Status: REOPENED → NEW

Comment 8

18 years ago
Reassign to bstell.

Updated

17 years ago
Keywords: intl

Comment 9

17 years ago
mark it as future. This only happen when the character cannot be encoded in the 
user's locale
Priority: -- → P4
Target Milestone: --- → Future
(Reporter)

Comment 10

17 years ago
How then it is possible to get the ugly charset name string on window title even
if the text is in charset (ISO-8859-1 or ISO-8859-15) which can be shown very 
well and share good deal of the character repertoire.

BTW, I think this bug may also have something to do with XFree86 4.x's increased 
knowledge of "international" charsets.

Comment 11

17 years ago
cc katakai

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 12

17 years ago
switching qa contact to ylong.
QA Contact: andreasb → ylong

Comment 13

17 years ago
*** Bug 90803 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
This seems to affect only to window managers that use WM_NAME(COMPOUND_TEXT).
New window managers seem to use _NET_WM_NAME(UTF8_STRING) property. (bug 90803)

Comment 15

17 years ago
--> ftang
Assignee: bstell → ftang
Status: ASSIGNED → NEW

Comment 16

17 years ago
bulk move NEW FUTURE bug to ASSIGN
Status: NEW → ASSIGNED

Comment 17

14 years ago
-> to default owner (rather than ftang's WONTFIX)
Assignee: ftang → smontagu
Status: ASSIGNED → NEW
Target Milestone: Future → ---
(Assignee)

Comment 18

12 years ago
Duping (to later bug but with more information)

*** This bug has been marked as a duplicate of 150131 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.