Unread counts of folders do not refresh on checking for mail

RESOLVED DUPLICATE of bug 324375

Status

RESOLVED DUPLICATE of bug 324375
7 years ago
7 years ago

People

(Reporter: firstpeterfourten, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I have IMAP accounts with lots of subfolders and filters that automatically sort incoming messages into them.  I have multiple computers (e. g. home and work) with the same account and similar filter setups, so they're both accessing the same IMAP server accounts and both loading the same set of messages.

If I load messages at the end of the day at work, I might see that Folder A has 6 unread messages because it's bold and has the number 6 next to it; similarly Folder B has 35.  Then I go home and on my home computer, I read all six messages in Folder A and five in Folder B. On that computer the Folder A name goes to regular-weight text and the number in parentheses disappears; Folder B's is updated to "(30)".  The next day I go back to work and check e-mail again, and even after a while of being there & even reading/responding to messages that are new since my last access from home, I see Folder A as bolded with (6) and Folder B displaying (35).
When I click on the folder name to see if additional messages have actually come in to account for that, the count is updated to be correct.

I would like to see the counts updated automatically when downloading messages.  I have over 100 folders and it's not a good use of time to be clicking through all the folders and waiting for that count to be updated, when it could so clearly be automated as part of the syncing process.
(Reporter)

Comment 1

7 years ago
Edit: This bug may be related to Bug 324375, where it is described with POP.
Does it help if you run Thunderbird in -safe-mode ?

Does rebuilding the folder's index solves the issue ?

Marking as dup for now.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 324375
You need to log in before you can comment on or make changes to this bug.