Last Comment Bug 708643 - If Firebug is installed, using "Inspect Element" twice results in 2 inspectors, one uncloseable.
: If Firebug is installed, using "Inspect Element" twice results in 2 inspector...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: 10 Branch
: x86 Mac OS X
: -- normal (vote)
: Firefox 13
Assigned To: Nobody; OK to take it and work on it
:
: Patrick Brosset <:pbro>
Mentors:
: 728491 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-08 08:37 PST by Jody McIntyre
Modified: 2012-04-12 07:09 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Uncloseable inspector on top of google.ca (240.54 KB, image/png)
2011-12-08 08:37 PST, Jody McIntyre
no flags Details
Two inspectors on top of google.ca (268.99 KB, image/png)
2011-12-08 08:38 PST, Jody McIntyre
no flags Details
patch v1 (1.33 KB, patch)
2012-02-06 07:29 PST, Paul Rouget [:paul]
dcamp: review+
Details | Diff | Splinter Review

Description Jody McIntyre 2011-12-08 08:37:29 PST
Created attachment 580057 [details]
Uncloseable inspector on top of google.ca

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_7) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.121 Safari/535.2

Steps to reproduce:

Aurora version 10.0a2

1. Loaded a page
2. Right click -> Inspect Element
3. Right click -> Inspect Element again
4. Exit the inspector using X on the inspector bar.


Actual results:

After step 3, a new inspector appears on top of the old one.

After step 4, the inspector bar disappears but the screen remains greyed out and the inspector box and bubble remains visible.  Reloading the page doesn't help.  Running Inspector again doesn't help.  Visiting another page causes the screen to remain greyed out with the inspector box and bubble.


Expected results:

After step 3, I expect the element to appear in the existing inspector.

After step 4, I expect the inspector to disappear.

I've only been able to reproduce this problem using a confidential internal application.  I can visit another page after step 4, and I will attach a screenshot of what that looks like (and another with 2 inspectors.)
Comment 1 Jody McIntyre 2011-12-08 08:38:09 PST
Created attachment 580058 [details]
Two inspectors on top of google.ca
Comment 2 Tim (fmdeveloper) 2011-12-08 12:22:57 PST
Can you also test the latest nightly? http://nightly.mozilla.org/
Comment 3 Jody McIntyre 2011-12-11 07:54:46 PST
(In reply to Tim (fmdeveloper) from comment #2)
> Can you also test the latest nightly? http://nightly.mozilla.org/

Unfortunately I can no longer reproduce this in Aurora (which updated itself) or in the latest nightly.  It was difficult to reproduce to begin with so I'm not sure if it's been fixed or if it's just not happening anymore.  Feel free to resolve this as WORKSFORME...
Comment 4 Tim (fmdeveloper) 2011-12-11 17:46:22 PST
Will close - if you are able to reproduce again please do post back!
Comment 5 jonmhargett 2012-02-03 12:33:28 PST
I am experiencing this exact problem on an internal page that I am working on. I am using the 10.0 release for Windows.
Comment 6 jonmhargett 2012-02-03 12:58:15 PST
Here is a little more information and a test page where I can reproduce this every time.
Test Page: http://webpages.charter.net/jhargett/firefox_insp_test.html

Steps:
1. Right click on the INPUT element with the label "Name".
2. Click "Inspect Element" in the context menu.
3. While the Inspector is still open and has the screen "dimmed", right click on the SELECT element with the label "Select".
4. Click the "Inspect Element" option in the context menu.

Instead of moving the bubble to the SELECT element, it opens a new Inspector window on top of the old one (this is noticeable because the screen gets even dimmer.) It can't find the SELECT element so it goes in to Inspector mode where it puts a bubble over whatever element you mouse over. If you close that inspector, the original one stays open with no way to close it. The only solution at this point is to close the tab and start over.
Comment 7 Dave Camp (:dcamp) 2012-02-03 13:01:29 PST
Paul, I can reproduce this on nightly, can you take a look please?
Comment 8 Paul Rouget [:paul] 2012-02-03 13:36:14 PST
I must be missing something. I can't reproduce. I can't right click on the SELECT element (there's no contextual menu for this element).
Comment 9 jonmhargett 2012-02-03 14:11:23 PST
Maybe it is an issue with a different OS? I am on WinXP PRO SP3. I am using FF 10.0. Here is a screencast of it happening on my computer:

http://webpages.charter.net/jhargett/firefox_bug.mp4
Comment 10 Dave Camp (:dcamp) 2012-02-03 14:16:12 PST
I can't trigger this on win7(aurora), but can trigger on osx 10 (nightly)
Comment 11 Paul Rouget [:paul] 2012-02-03 14:59:48 PST
Apparently, Firebug needs to be installed to reproduce this bug.
Comment 12 Paul Rouget [:paul] 2012-02-03 15:00:30 PST
jonmhargett, do you have Firebug installed?
Comment 13 jonmhargett 2012-02-03 15:04:18 PST
Yes. I will retest with it disabled.
Comment 14 jonmhargett 2012-02-03 19:09:08 PST
That was it. I disabled firebug and now the context menu is not available when I right click on a SELECT element. This problem exists with Firebug 1.9.1. So, what is the solution: should Firebug fix this or should you guys make it so that SELECT elements are clickable and the inspector switches to that element?
Comment 15 Paul Rouget [:paul] 2012-02-06 06:21:21 PST
Looks fixed in Firebug 1.10.
Comment 16 Paul Rouget [:paul] 2012-02-06 07:29:16 PST
Created attachment 594706 [details] [diff] [review]
patch v1

It's not "fixed" in Firebug 1.10, it's just that the right-click-on-form feature is broken in 1.10.

The problem is that Firebug allows right-click on forms, and this behavior is not supported by the builin inspector yet: we get a call to openInspectorUI(this.target) where target is null. We don't correctly test this 
This patch fix this test. I opened bug 724546 to support right click on forms.
Comment 17 Paul Rouget [:paul] 2012-02-06 22:03:21 PST
This should be landed in Beta and Aurora too.
Comment 19 Tim Taubert [:ttaubert] 2012-02-07 11:24:15 PST
https://hg.mozilla.org/mozilla-central/rev/7744c59bfdc1
Comment 20 Paul Rouget [:paul] 2012-04-04 05:30:22 PDT
*** Bug 728491 has been marked as a duplicate of this bug. ***
Comment 21 Basil Mohamed Gohar 2012-04-12 07:09:59 PDT
For what it's worth, this is also an issue on Fedora 14, and I assume, other Linux distributions as well.  I would have had a hard time figuring out that it was related to having Firebug installed, so good work, guys.

Note You need to log in before you can comment on or make changes to this bug.