Last Comment Bug 708701 - Implement HTML event ctors
: Implement HTML event ctors
Status: RESOLVED FIXED
: dev-doc-needed
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug]
:
Mentors:
Depends on: 675884
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-08 10:07 PST by Olli Pettay [:smaug]
Modified: 2011-12-15 16:17 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (18.83 KB, patch)
2011-12-08 11:43 PST, Olli Pettay [:smaug]
no flags Details | Diff | Splinter Review
patch (24.95 KB, patch)
2011-12-08 13:17 PST, Olli Pettay [:smaug]
jst: review+
Details | Diff | Splinter Review
up-to-date (24.96 KB, patch)
2011-12-13 05:13 PST, Olli Pettay [:smaug]
no flags Details | Diff | Splinter Review

Description Olli Pettay [:smaug] 2011-12-08 10:07:59 PST
HTML spec defines few events and has event ctors for them
Comment 1 Olli Pettay [:smaug] 2011-12-08 11:43:49 PST
Created attachment 580124 [details] [diff] [review]
patch

There can be some more events, but we don't support them fully atm anyway.
Comment 2 Olli Pettay [:smaug] 2011-12-08 11:52:54 PST
https://tbpl.mozilla.org/?tree=Try&rev=280d802bd25c
Comment 3 Olli Pettay [:smaug] 2011-12-08 12:09:15 PST
Comment on attachment 580124 [details] [diff] [review]
patch

Bah, I need to check whether those string attributes exist, since otherwise
they get value "undefined"
Comment 4 Olli Pettay [:smaug] 2011-12-08 13:17:56 PST
Created attachment 580166 [details] [diff] [review]
patch

This is not so nice, but xpconnect's js->c++ just behaves in a wrong way in
'string' case.
Comment 5 Olli Pettay [:smaug] 2011-12-13 05:13:11 PST
Created attachment 581232 [details] [diff] [review]
up-to-date
Comment 6 Olli Pettay [:smaug] 2011-12-14 12:38:51 PST
https://hg.mozilla.org/mozilla-central/rev/141ae3a6ccd2

Note You need to log in before you can comment on or make changes to this bug.