Last Comment Bug 708774 - Make landscape keyboard be fullscreen
: Make landscape keyboard be fullscreen
Status: VERIFIED FIXED
[VKB][not-fennec-11]
: inputmethod
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: Firefox 12
Assigned To: Matt Brubeck (:mbrubeck)
:
Mentors:
Depends on: 714950
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-08 11:59 PST by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2012-03-02 08:56 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified


Attachments
patch (1.10 KB, patch)
2012-01-06 10:41 PST, Matt Brubeck (:mbrubeck)
mark.finkle: review+
blassey.bugs: approval‑mozilla‑beta+
Details | Diff | Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2011-12-08 11:59:11 PST
There is not enough space in landscape to show the keyboard and content at the same time. Some may argue we could try real hard to make more space, but it's not worth it.

When we are in landscape, let's use the fullscreen keyboard.
Comment 1 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-16 15:06:58 PST
This looks fixed in tinderbox build.
Comment 2 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-16 15:08:24 PST
Oops.  I tried the about:config text box and it was not full screen there.  Nor at www.google.com.  Closed too early.  URL bar is fullscreen though.
Comment 3 Alex Pakhotin (:alexp) 2011-12-22 11:33:19 PST
I've found that after the recent major change the full-screen UI is not working, I'm looking into that.

What else is involved in this except setting the preference?
Comment 4 Matt Brubeck (:mbrubeck) 2012-01-06 10:41:55 PST
Created attachment 586477 [details] [diff] [review]
patch

Just setting the pref seems to be sufficient.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-06 10:59:37 PST
Comment on attachment 586477 [details] [diff] [review]
patch

this shouldn't affect tablets
Comment 6 Matt Brubeck (:mbrubeck) 2012-01-06 11:18:09 PST
This can't land until the blocking bug 714950 is fixed.

(In reply to Mark Finkle (:mfinkle) from comment #5)
> this shouldn't affect tablets

Actually, this patch will *only* affect devices with 5" or larger displays (approximately), like the 7" Galaxy Tab.  If you were seeing non-fullscreen keyboards on a smaller device, then this patch might not fix the problem.  On what devices can you reproduce this bug?
Comment 7 Aaron Train [:aaronmt] 2012-01-06 11:24:00 PST
I get full-screen keyboard right now on the Nexus S which is 4".
Comment 8 Matt Brubeck (:mbrubeck) 2012-01-06 11:28:09 PST
Right, that's expected.  The "bug" here is that some devices show a *non-fullscreen* keyboard.

Current behavior (without patch): Fullscreen keyboard when available on devices less than about 5", non-fullscreen keyboard on devices greater than about 5".

New behavior (with patch): Fullscreen keyboard when available on all devices.  (Some devices like honeycomb tablets do not have a full-screen keyboard mode.)
Comment 9 Alex Pakhotin (:alexp) 2012-01-25 17:49:13 PST
Does this need anything else?
Comment 10 Matt Brubeck (:mbrubeck) 2012-01-26 13:58:37 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/0ec894d6c37c

I don't think we need this on Aurora.  It's a very minor tweak that affects only a small minority of devices (certain 5" to 7" tablets) and is unlikely to cause merge conflicts.  Please re-nominate if you disagree.
Comment 11 Matt Brubeck (:mbrubeck) 2012-01-27 09:09:55 PST
https://hg.mozilla.org/mozilla-central/rev/0ec894d6c37c
Comment 12 Brad Lassey [:blassey] (use needinfo?) 2012-01-27 23:50:46 PST
Matt, please request aurora approval
Comment 13 Matt Brubeck (:mbrubeck) 2012-01-28 09:38:11 PST
Marking as not-fennec-11; see comment 10 for rationale.
Comment 14 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 11:02:57 PST
Comment on attachment 586477 [details] [diff] [review]
patch

[Triage Comment]
Comment 15 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 13:05:42 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/2ad1f1ed0e2f
Comment 16 Cristian Nicolae (:xti) 2012-03-02 08:56:02 PST
Verified fixed on:

Firefox 13.0a1 (2012-03-02)
20120302031112
http://hg.mozilla.org/mozilla-central/rev/3a7b9e61c263

--
Device: Samsung Galaxy S2
OS: Android 2.3.4

Note You need to log in before you can comment on or make changes to this bug.