ACR shouldn't disable compatibility checking when compatibly-by-default is enabled

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: Unfocused, Assigned: Unfocused)

Tracking

Details

Attachments

(1 attachment)

ARC currently clashes with compatible-by-default. At the very least, it shouldn't disable compatibility checking when compatibile-by-default is enabled.
Created attachment 580275 [details] [diff] [review]
Patch v1
Attachment #580275 - Flags: review?(fligtar)
Comment on attachment 580275 [details] [diff] [review]
Patch v1

Looks good and seems to do the trick. Checked in r98544 as you don't have commit access to that area most likely.
Attachment #580275 - Flags: review?(fligtar) → review+
I did some basic testing and it seemed to work fine. I went ahead and pushed out version 1.0.1 to AMO: https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/

Thanks
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 4

7 years ago
Looks good to me as well, on a quick glance.

Dave, can you please review this patch as well.

Comment 6

7 years ago
This fix also caused breakage in Firefox 3.6, fixed now (along with other unrelated fixage) in r98794.

Comment 7

7 years ago
A user is reporting that incompatible add-ons are being disabled with that update, that were previously enabled. If CBD is enabled, this should not happen right?

https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/reviews/326063/
(In reply to Brian King (Briks) [:kinger] from comment #7)
> A user is reporting that incompatible add-ons are being disabled with that
> update, that were previously enabled. If CBD is enabled, this should not
> happen right?

The problem is that CBD does not enable *all* addons, see:

http://theunfocused.net/2011/11/19/solving-firefoxs-add-on-compatibility-problem/

So when a user upgrades from ACR 1.0 -> ACR 1.0.1, their old (e.g. 3.6-only) addons will be disabled.

I'm not really sure of the solution to this. We can maybe:

- Continue to set extensions.checkCompatibility.* to false. How does this clash with CBD? What happens when this prefs goes away for v12+

- Somehow force compatibility of old addons on a per-addon basis within the Addon Manager.

- Accept that old addons will not be compatible going forward.


See also my comments in bug 709225.
A good example is in this bug 709197

The "Linkification" add-on is marked as compatible only till 3.6. With CBD browsers with ACR installed, there is no way to use this addon:

- CBD won't enable this addon because it is too old (3.6)
- ACR won't enable this addon because it won't set the checkCompatibility pref = false for a CBD browser.
(In reply to David McNamara [:mackers] from comment #8)
> I'm not really sure of the solution to this. We can maybe:
> 
> - Continue to set extensions.checkCompatibility.* to false. How does this
> clash with CBD? What happens when this prefs goes away for v12+

There is a summary of the clash at:
https://bugzilla.mozilla.org/show_bug.cgi?id=698653#c14

Internally I am not sure what is going on.

Blair, is this by design? Shoudl we not bother trying to get the two to play nice?

> - Somehow force compatibility of old addons on a per-addon basis within the
> Addon Manager.
> 
> - Accept that old addons will not be compatible going forward.

IIRC, 'Compat by Default' does not support add-ons with maxVer less than 4. I don't think we should put much effort into it either, unless someone feels strongly about it.
(In reply to Brian King (Briks) [:kinger] from comment #10)
> Blair, is this by design? 

For my patch, yes. Sadly, I couldn't think of an easy way to make these things co-exist peacefully. Globally disabling compatibility checking is such a big hammer :(

> Should we not bother trying to get the two to play nice?

I'm not sure. At the moment, I'm far more concerned with just having compatible-by-default enabled (without compatibility checking disabled), as that's the long-term global solution. We know that won't fix 100% of cases, but it should be pretty close now.

I think I have a way to make the Addons Manager easily support force-enabling individual addons (as opposed to globally disabling compatibility checking). But I'm not sure it's something we even want to do.

> I don't think we should put much effort into it either, unless someone feels
> strongly about it.

Agreed. Personally, I'd like to see all the effort be put into the ACR rewrite (ie, the reporting side of ACR).
(In reply to Blair McBride (:Unfocused) from comment #11)
> Agreed. Personally, I'd like to see all the effort be put into the ACR
> rewrite (ie, the reporting side of ACR).

Still waiting on new spec from fligtar.

For now, will push out 1.0.2 today with fix for bug 709225.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.