The default bug view has changed. See this FAQ.

Submitting a new review hangs

VERIFIED WORKSFORME

Status

addons.mozilla.org Graveyard
Public Pages
--
major
VERIFIED WORKSFORME
5 years ago
a year ago

People

(Reporter: AlinT, Unassigned)

Tracking

({regression})

Details

(Whiteboard: [fromAutomation], URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Steps to reproduce:
1.Go to https://addons-dev.allizom.org and login with your browser ID
2.Go to adblock-plus addon and click write a review
3.Fill the message field, rate the addon and click submit review

Expected results:
Review should be saved and listed.

Actual results:
After click the submit button, AMO is non responsive and hangs for quite a while(aprox. 5 minutes or more).Strange enough, it doesn't timeout.

*Note: This issue is making some automated tests for AMO fails, due to the fact that tests time out.
(Reporter)

Updated

5 years ago
Severity: normal → major
OS: Windows 7 → All
Hardware: x86 → All
Keywords: regression
Whiteboard: [fromAutomation]

Comment 1

5 years ago
I cannot reproduce this. I was able to add a review. See https://addons-dev.allizom.org/en-US/firefox/addon/adblock-plus/reviews/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Created attachment 580480 [details]
Screenshot of Jenkins build results
Verified WFM; passing in our CI too, now -- must've been transient!
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

5 years ago
http://qa-selenium.mv.mozilla.com:8080/job/amo.dev.webdriver/74/
This is from today.
test_that_a_new_review is still failing.
I've runned the tests with the test account from webqa-credentials and this test is still failing, meaning it is still hanging. (it is also hanging when testing manually)
Curiously enough, i've runned the tests with a new account and the test passes.
Is there a problem with the test account?Or is there a problem with the amount of reviews this acount has?
I was able to reproduce this using the amo.testing account.

1. Logged into browser id with amo.testing
2. searched for adblock plus
3. clicked write review
4. wrote the review and was redirected to this page
https://addons-dev.allizom.org/en-US/firefox/addon/adblock-plus/reviews/add
5. added a title and star
6. clicked "submit review"
7. The page is stuck in it's request to submit the review
https://skitch.com/marlenacompton/gxi9f/add-a-review-for-adblock-plus-add-ons-for-firefox

So I opened firebug to get more info about the request:
https://skitch.com/marlenacompton/gxsyk/while-waiting

Here's info from after the page completed. I am curious about why include.js took 832ms to load:
https://skitch.com/marlenacompton/gxsyh/adblock-plus-reviews-add-ons-for-firefox
Spoke with Andy on irc.  He pointed out that it's a browserid request that is taking so long. Will file with them.  Leaving this one closed.
Here's the bug opened for the browser id team.  https://github.com/mozilla/browserid/issues/742
Summary: Submiting a new review hangs → Submitting a new review hangs
(Assignee)

Updated

a year ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.