Last Comment Bug 709005 - Sync the browser.sessionstore.restore_on_demand pref
: Sync the browser.sessionstore.restore_on_demand pref
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
:
Mentors:
: 714069 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 03:29 PST by Philipp von Weitershausen [:philikon]
Modified: 2011-12-29 21:36 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v0.1 (4.57 KB, patch)
2011-12-09 11:40 PST, Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
no flags Details | Diff | Review
Patch v0.2 (1.55 KB, patch)
2011-12-09 11:42 PST, Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
rnewman: review+
Details | Diff | Review

Description Philipp von Weitershausen [:philikon] 2011-12-09 03:29:19 PST
The browser.sessionstore.restore_on_demand pref is exposed in the UI in Firefox 8+, but unlike the other exposed session restore related prefs, it's not synced. We should fix this.

Also, for future reference, here's a general rule: if you're introducing a pref that (a) is exposed to the user in the UI, (b) is cross platform, and (c) something you would expect to sync across profiles and/or related to prefs that are already synced: add it to the list of synced prefs!
Comment 1 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-12-09 11:40:57 PST
Created attachment 580487 [details] [diff] [review]
Patch v0.1

I can fix [good first bug]s too
Comment 2 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-12-09 11:42:52 PST
Created attachment 580489 [details] [diff] [review]
Patch v0.2

derp. I can even attach patches that don't have other junk in them.
Comment 3 Richard Newman [:rnewman] 2011-12-09 12:21:52 PST
Comment on attachment 580489 [details] [diff] [review]
Patch v0.2

Review of attachment 580489 [details] [diff] [review]:
-----------------------------------------------------------------

Does what it says on the tin!

Please write up brief steps for QA to verify.
Comment 4 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-12-13 12:20:15 PST
Landed in fx-team: https://hg.mozilla.org/integration/fx-team/rev/8e9120a2a121

For QA to verify: check the "don't load tabs until selected" box in the general pref pane. Make sure that gets synced to a second machine.
Comment 5 Rob Campbell [:rc] (:robcee) 2011-12-14 06:40:45 PST
https://hg.mozilla.org/mozilla-central/rev/8e9120a2a121
Comment 6 Philipp von Weitershausen [:philikon] 2011-12-29 21:36:01 PST
*** Bug 714069 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.