Last Comment Bug 709039 - "Copy" keyboard shortcut closes the Scratchpad window Aurora 10.0a2
: "Copy" keyboard shortcut closes the Scratchpad window Aurora 10.0a2
Status: RESOLVED FIXED
DUPME
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Scratchpad (show other bugs)
: 10 Branch
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 05:47 PST by Olivier Audard
Modified: 2012-01-26 13:31 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Olivier Audard 2011-12-09 05:47:07 PST
User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.121 Safari/535.2

Steps to reproduce:

- Open the scrachpad window
- Usually select some text to copy (not mandatory)
- Hit Ctrl-C (or Cmd-C on Mac OS) to copy the text

Please note that clicking "copy" with the mouse from "Edit > Copy" menu works as expected.
(Also tested on MacOS X Lion and Windows 7)


Actual results:

The scrachpad windows closes itself and the selected text is not copied to clipboard.


Expected results:

The scrachpad window should remain open and the selected text should be copied to clipboard.
Comment 1 Paul Rouget [:paul] 2011-12-09 06:06:14 PST
Rob?
Comment 2 Paul Rouget [:paul] 2011-12-09 06:08:42 PST
(can't reproduce here, Nightly + Linux)

@Olivier, which version of Firefox do you use? Did you try with a nightly build?
Comment 3 Rob Campbell [:rc] (:robcee) 2011-12-09 06:13:43 PST
I can't reproduce on aurora 10. Do you have any add-ons installed?
Comment 4 Olivier Audard 2011-12-09 06:21:23 PST
@Rob: I tested on Aurora 10.0a2 and I still have it with all add-ons disabled.
Should I try to uninstall them?
Comment 5 Leonard Camacho [:lcamacho] 2011-12-09 07:52:47 PST
I can reproduce this with aurora and a new profile, ubuntu 32 bits

Mozilla/5.0 (X11; Linux i686; rv:10.0a2) Gecko/20111209 Firefox/10.0a2
Comment 6 Olivier Audard 2011-12-09 09:30:07 PST
Seems to work fine in nightly + ubuntu (I will test on Mac OS X later).
Comment 7 Leonard Camacho [:lcamacho] 2011-12-09 11:53:10 PST
I also reproduce this in nightly but I now the reason I'm using es_AR localization and there's a coincidence between the shortcuts of Copy and Close, both are Ctrl+C, so is just a problem with shortcuts in my case.
Comment 8 David Bruant 2012-01-07 08:00:25 PST
This keeps happening. I've tried Ctrl+C on several builds and here are the results:
Scratchpad closes with Ctrl+C in Happens in:
* Beta 10.0
http://hg.mozilla.org/releases/mozilla-beta/rev/e45fb547926c
* Aurora 11.0a2 (2012-01-07)
http://hg.mozilla.org/releases/mozilla-aurora/rev/cd69196df47d


Does not close in:
* Stable 9.0.1
* Nightly 11.0a1 (2011-12-17) (I hadn't updated for a while)
* Nightly 12.0a1 (2012-01-07)

I'm running on Ubuntu 11.04 (Natty) (which is not the latest).
All tests have been performed with the same add-ons on all builds.
Comment 9 David Bruant 2012-01-07 08:04:10 PST
For the beta and the nightly, the scratchpad closes also with a profile with only about:telemetry and test pilot.
Comment 10 David Bruant 2012-01-07 08:04:26 PST
For the beta and the nightly, the scratchpad closes also with a profile with only about:telemetry and test pilot.
Comment 11 Jesper Hansen 2012-01-08 14:16:21 PST
Although scratchpad.dtd doesn't appear to have modified, it could be a valid point to check out:
chrome://browser/locale/devtools/scratchpad.dtd
<!ENTITY closeCmd.key                 "W">

Does ctrl+w also close your window along with ctrl+c?
Comment 12 Leonard Camacho [:lcamacho] 2012-01-09 04:14:54 PST
I create this bug 716495 to fix this problem on es-AR localization
Comment 13 Rob Campbell [:rc] (:robcee) 2012-01-25 08:42:50 PST
I think this is likely a localization issue. Please reopen if the problem persists.
Comment 14 David Bruant 2012-01-25 10:54:49 PST
On Aurora, Ctrl+C closes the scratchpad but Ctrl+W is fine.
On Nightly, Ctrl+W closes the scratchpad but Ctrl+C is fine.

(In reply to Rob Campbell [:rc] (robcee) from comment #13)
> I think this is likely a localization issue.
How can I discriminate if it is or not?
Comment 15 Rob Campbell [:rc] (:robcee) 2012-01-26 08:42:55 PST
(In reply to David Bruant from comment #14)
> On Aurora, Ctrl+C closes the scratchpad but Ctrl+W is fine.
> On Nightly, Ctrl+W closes the scratchpad but Ctrl+C is fine.
> 
> (In reply to Rob Campbell [:rc] (robcee) from comment #13)
> > I think this is likely a localization issue.
> How can I discriminate if it is or not?

Are you using a non en-US version of Firefox?

What does navigator.language tell you in the Web Console?
Comment 16 Rob Campbell [:rc] (:robcee) 2012-01-26 08:49:05 PST
also, see bug 716495. If you're using es-AR, I'll dupe this bug to that one.

thanks!
Comment 17 David Bruant 2012-01-26 13:31:15 PST
(In reply to Rob Campbell [:rc] (robcee) from comment #15)
> Are you using a non en-US version of Firefox?
> 
> What does navigator.language tell you in the Web Console?
fr-FR. I tried an en-US browser and it worked fine. I just noticed the problem for fr-FR is the same than es-AR. Reopening bug 716495

Thanks for the help :-)

Note You need to log in before you can comment on or make changes to this bug.