Please create a Grow Mozilla wordmark with ReMo logo

RESOLVED DUPLICATE of bug 713641

Status

RESOLVED DUPLICATE of bug 713641
7 years ago
7 years ago

People

(Reporter: davidwboswell, Assigned: rhonda)

Tracking

Details

(Whiteboard: --on hold--)

(Reporter)

Description

7 years ago
We would like to create a Grow Mozilla wordmark using the red ReMo badge logo.

'Grow Mozilla' and 'Mozilla Reps' are related so this should be similar to the existing ReMo logo and wordmark:

https://wiki.mozilla.org/images/4/47/Remo_logo_vertical.png

Perhaps have the logo on the left and then 'grow mozilla' text stacked vertically.

Comment 1

7 years ago
Thanks David.  What is your timing on this?
Assigning to Rhonda :)
Assignee: tshahian → rspencer
(Reporter)

Comment 2

7 years ago
Tara, it's not urgent.  Ideally we'd have something in January to roll things out.  I also set up some time to talk to you more about this tomorrow to get your advice and suggestions.

Comment 3

7 years ago
sounds good. Thanks David :)

Comment 4

7 years ago
Hey David, all--

We're also kicking off a re-brand for the Student Reps program, keeping the name 'Mozilla Student Reps' and aiming to hold on to the fun collegiate brand-feel. The main goal is to redesign the visuals (logo, wordmark) to be more in line with Mozilla Reps branding. See bug 691919 for more info.

Given our team's recent discussions about creating cohesive and coordinated communications, it sounds pertinent to synch up our efforts and creative direction with these recent logo projects.
(Reporter)

Comment 5

7 years ago
Jason, thanks for the heads up about the Student Reps logo redesign -- I agree that it would be good to coordinate to make sure things fit together holistically.

For more context, the Grow Mozilla program is putting the different pieces of Contributor Engagement's strategy into one overall package.  This includes the existing Mozilla Reps and Mozilla Student Reps projects that have some visual identity plus Mozilla Stewards and Mozilla Leaders that don't yet have any visual identity.

Comment 6

7 years ago
Creative team:  We'll hold on this + the Student Reps logo redesign for now. David will share out an outline of the holistic "Grow Mozilla" program - we'd like to create a brand hierarchy for the whole program that shows continuity and builds upon each other :)

Updated

7 years ago
Status: NEW → ASSIGNED

Updated

7 years ago
Whiteboard: --on hold--
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 713641
You need to log in before you can comment on or make changes to this bug.