Last Comment Bug 709523 - Remove dead editor code
: Remove dead editor code
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
Mentors:
Depends on:
Blocks: deadcode
  Show dependency treegraph
 
Reported: 2011-12-10 14:39 PST by :Ms2ger (⌚ UTC+1/+2)
Modified: 2011-12-11 12:05 PST (History)
3 users (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part a: nsDOMSubtreeIterator::Init (1.79 KB, patch)
2011-12-10 14:39 PST, :Ms2ger (⌚ UTC+1/+2)
ehsan: review+
Details | Diff | Splinter Review
Part b: nsDOMIterator::ForEach (2.22 KB, patch)
2011-12-10 14:40 PST, :Ms2ger (⌚ UTC+1/+2)
ehsan: review+
Details | Diff | Splinter Review
Part c: EditAggregateTxn::{GetCount,GetTxnAt,SetName} (2.48 KB, patch)
2011-12-10 14:41 PST, :Ms2ger (⌚ UTC+1/+2)
ehsan: review+
Details | Diff | Splinter Review
Part d: nsHTMLEditor::IsRootTag (2.84 KB, patch)
2011-12-10 14:42 PST, :Ms2ger (⌚ UTC+1/+2)
ehsan: review+
Details | Diff | Splinter Review
Part e: Some overloads of TypeInState::{SetProp,ClearProp} (4.28 KB, patch)
2011-12-10 14:43 PST, :Ms2ger (⌚ UTC+1/+2)
ehsan: review+
Details | Diff | Splinter Review
Part f: nsHTMLEditUtils::IsAddress (2.46 KB, patch)
2011-12-10 14:44 PST, :Ms2ger (⌚ UTC+1/+2)
ehsan: review+
Details | Diff | Splinter Review
Part g: nsHTMLEditRules::{Will,Did}DeleteRange (2.30 KB, patch)
2011-12-10 14:45 PST, :Ms2ger (⌚ UTC+1/+2)
ehsan: review+
Details | Diff | Splinter Review
Part h: Unused variable in nsHTMLEditor::GetBodyElement (776 bytes, patch)
2011-12-11 07:40 PST, :Ms2ger (⌚ UTC+1/+2)
ehsan: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2011-12-10 14:39:37 PST
Created attachment 580681 [details] [diff] [review]
Part a: nsDOMSubtreeIterator::Init

Because there's so much of it I'm not going to file a bug per patch.
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2011-12-10 14:40:12 PST
Created attachment 580682 [details] [diff] [review]
Part b: nsDOMIterator::ForEach
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2011-12-10 14:41:20 PST
Created attachment 580683 [details] [diff] [review]
Part c: EditAggregateTxn::{GetCount,GetTxnAt,SetName}
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2011-12-10 14:42:21 PST
Created attachment 580684 [details] [diff] [review]
Part d: nsHTMLEditor::IsRootTag
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2011-12-10 14:43:09 PST
Created attachment 580685 [details] [diff] [review]
Part e: Some overloads of TypeInState::{SetProp,ClearProp}
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2011-12-10 14:44:07 PST
Created attachment 580686 [details] [diff] [review]
Part f: nsHTMLEditUtils::IsAddress
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2011-12-10 14:45:06 PST
Created attachment 580687 [details] [diff] [review]
Part g: nsHTMLEditRules::{Will,Did}DeleteRange
Comment 7 :Ms2ger (⌚ UTC+1/+2) 2011-12-11 07:40:06 PST
Created attachment 580740 [details] [diff] [review]
Part h: Unused variable in nsHTMLEditor::GetBodyElement
Comment 8 :Ehsan Akhgari 2011-12-11 11:39:39 PST
Comment on attachment 580686 [details] [diff] [review]
Part f: nsHTMLEditUtils::IsAddress

So, we were including a hear for bool!  Nice :P
Comment 9 :Ehsan Akhgari 2011-12-11 11:41:03 PST
Nice work, thanks Ms2ger!

Note You need to log in before you can comment on or make changes to this bug.