Last Comment Bug 709709 - Remove unused nsDragService::GetShellVersion
: Remove unused nsDragService::GetShellVersion
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal (vote)
: mozilla11
Assigned To: Makoto Kato [:m_kato]
:
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks: deadcode
  Show dependency treegraph
 
Reported: 2011-12-11 23:39 PST by Makoto Kato [:m_kato]
Modified: 2011-12-12 17:52 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (2.17 KB, patch)
2011-12-12 01:10 PST, Makoto Kato [:m_kato]
jmathies: review+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] 2011-12-11 23:39:32 PST
This is unused.  We should remove this.


http://mxr.mozilla.org/mozilla-central/ident?i=GetShellVersion

    widget/src/windows/nsDragService.cpp (View Hg log or Hg annotations)
        line 616, as member of class nsDragService -- PRUint64 nsDragService::GetShellVersion() 

Defined as a function prototype in:

    widget/src/windows/nsDragService.h (View Hg log or Hg annotations)
        line 89 -- PRUint64 GetShellVersion(); 

Defined as a variable in:

    mobile/xul/chrome/content/Util.js (View Hg log or Hg annotations)
        line 182 -- let shellVersion = sysInfo.get("shellVersion") || ""; 

Referenced (in 2 files total) in:

    xpcom/base/nsSystemInfo.cpp (View Hg log or Hg annotations)
        line 201 -- SetPropertyAsAString(NS_LITERAL_STRING("shellVersion"), str); 
    mobile/xul/chrome/content/Util.js (View Hg log or Hg annotations)
        line 183 -- let matches = shellVersion.match(/\((\d+)\)$/);
Comment 1 Makoto Kato [:m_kato] 2011-12-12 01:10:49 PST
Created attachment 580854 [details] [diff] [review]
fix
Comment 2 Jim Mathies [:jimm] 2011-12-12 10:51:41 PST
Comment on attachment 580854 [details] [diff] [review]
fix

This looks fine. From the shellVersion code in sys info, it looks like this is only in use on Android?

(More bug 709193 work.)
Comment 3 Makoto Kato [:m_kato] 2011-12-12 17:01:40 PST
(In reply to Jim Mathies [:jimm] from comment #2)
> Comment on attachment 580854 [details] [diff] [review]
> fix
> 
> This looks fine. From the shellVersion code in sys info, it looks like this
> is only in use on Android?
> 
> (More bug 709193 work.)

Yes.

Also nsDragService::GetShellVersion() into windows widget is used on Gecko 1.9.2, but this is no longer used on Gecko 2.0 or later
Comment 4 Makoto Kato [:m_kato] 2011-12-12 17:52:45 PST
https://hg.mozilla.org/mozilla-central/rev/f16d056c532b

Note You need to log in before you can comment on or make changes to this bug.