Last Comment Bug 709712 - WebGL demos causing repeatable crashes
: WebGL demos causing repeatable crashes
Status: RESOLVED FIXED
[MTD], [native-crash]
: crash, reproducible
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: Trunk
: ARM Android
: -- critical (vote)
: mozilla9
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.chromeexperiments.com/webgl
: 709252 (view as bug list)
Depends on: 709947
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-11 23:49 PST by Matt Evans [:mevans]
Modified: 2011-12-17 11:01 PST (History)
5 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Nightly (12/12) Crash Log (10.93 KB, text/plain)
2011-12-12 11:50 PST, Aaron Train [:aaronmt]
no flags Details

Description Matt Evans [:mevans] 2011-12-11 23:49:38 PST
Web page or screen you were on when you saw the issue: 

Steps to reproduce:
1. go to this webgl test: https://cvs.khronos.org/svn/repos/registry/trunk/public/webgl/sdk/demos/google/shiny-teapot/index.html
2. 
3. 

What you expected: 

A teapot displayed

Actual:

Crash

Crash report ID (if applicable): 

https://crash-stats.mozilla.com/report/index/bp-deffd20c-dca2-4d2c-9877-5a3172111211


I believe other tests in the suite will cause similar crashes. Need to check more of these tests in this suite.
Comment 1 Benoit Jacob [:bjacob] (mostly away) 2011-12-12 07:20:18 PST
Shouldn't we group together all those malloc-related crashes triggered by WebGL demos on Android? For all we can see, they're likely all the same bug.
Comment 2 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-12 10:32:00 PST
Benoit, I was thinking the same thing.  

How would you like me to group them?
Should I go ahead and dup or do you want me to create a meta bug or do you want me to create a whiteboard tag?
Comment 3 Aaron Train [:aaronmt] 2011-12-12 11:50:09 PST
Created attachment 580993 [details]
Nightly (12/12) Crash Log

On every single demo at http://www.chromeexperiments.com/webgl, Fennec Native crashes. 

Attached is an example crash log.

--
Samsung Galaxy SII (Android 2.3.6)
Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111212 Firefox/11.0a1 Fennec/11.0a1
Comment 4 Aaron Train [:aaronmt] 2011-12-12 11:59:00 PST
*** Bug 709252 has been marked as a duplicate of this bug. ***
Comment 5 Benoit Jacob [:bjacob] (mostly away) 2011-12-12 12:52:51 PST
I'm testing a patch that makes us revert to using the GLSL backend instead of the ESSL backend in the ANGLE compiler. Shouldn't make a behavior difference anyway, as on ES we're just passing the original shader source to the driver, but could avoid this crash if it's related to the ESSL backend.

https://tbpl.mozilla.org/?tree=Try&rev=72ded8c7f176

Builds and logs will be available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/bjacob@mozilla.com-72ded8c7f176
Comment 6 Benoit Jacob [:bjacob] (mostly away) 2011-12-12 13:30:33 PST
We were able to confirm on AaronMT's phone that this patch fixes the crash.
Comment 7 Benoit Jacob [:bjacob] (mostly away) 2011-12-14 12:02:04 PST
Fixed by 709947
Comment 8 Scoobidiver (away) 2011-12-17 11:01:13 PST
The fix has been backported to Gecko 9+.

Note You need to log in before you can comment on or make changes to this bug.