Last Comment Bug 709747 - Support nsCOMPtr<T>::forget(I**)
: Support nsCOMPtr<T>::forget(I**)
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
:
Mentors:
Depends on:
Blocks: 708754
  Show dependency treegraph
 
Reported: 2011-12-12 03:45 PST by :Ms2ger (⌚ UTC+1/+2)
Modified: 2012-06-29 22:52 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.17 KB, patch)
2011-12-12 03:45 PST, :Ms2ger (⌚ UTC+1/+2)
benjamin: review+
Details | Diff | Splinter Review
Fix the COMPtr logging (1.30 KB, patch)
2012-06-27 17:07 PDT, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
dbaron: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2011-12-12 03:45:35 PST
Created attachment 580873 [details] [diff] [review]
Patch v1

As in bug 489705.
Comment 1 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-12-12 05:14:55 PST
I love you.
Comment 2 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-12-12 08:16:58 PST
Comment on attachment 580873 [details] [diff] [review]
Patch v1

Wait, the reason the old code called swap on a temp ptr was for comptr logging. Your current patch skips all that. Are you sure this won't mess up the comptr logging scripts?
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2011-12-18 07:08:45 PST
https://hg.mozilla.org/mozilla-central/rev/82bc89d8e3c3
Comment 4 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-12-18 09:13:53 PST
Ms2ger, you didn't address comment 2. Do our leak scripts handle this?
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2011-12-18 11:45:45 PST
No idea.
Comment 6 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-01-05 07:16:55 PST
Yeah, I think this needs to use NSCAP_LOG_RELEASE to make nsCOMPtr logging work again.
Comment 7 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-27 17:07:43 PDT
Created attachment 637311 [details] [diff] [review]
Fix the COMPtr logging
Comment 8 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-06-27 17:26:53 PDT
Comment on attachment 637311 [details] [diff] [review]
Fix the COMPtr logging

r=dbaron
Comment 9 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-29 11:56:11 PDT
https://hg.mozilla.org/mozilla-central/rev/027b86239bf3
Comment 10 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-06-29 13:41:36 PDT
Er, ugh, now that I look again, we shouldn't have made the second change, since nsCOMPtr<nsISupports>::forget(nsISupports**) uses swap().
Comment 11 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-06-29 22:52:00 PDT
Previous patch half backed out in https://hg.mozilla.org/mozilla-central/rev/f08d285b63b0 , so things should now be good.

Note You need to log in before you can comment on or make changes to this bug.