If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox crash in nsSocketTransportService::OnDispatchedEvent @ PR_SetPollableEvent

RESOLVED DUPLICATE of bug 662330

Status

()

Core
Networking
--
critical
RESOLVED DUPLICATE of bug 662330
6 years ago
2 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
Happens on version up to trunk. No bug on file tracking so creating this bug.

https://crash-stats.mozilla.com/report/list?signature=PR_SetPollableEvent

https://crash-stats.mozilla.com/report/index/03cee9d9-d5d6-4502-9bbf-a5fde2111206

Frame 	Module 	Signature [Expand] 	Source
0 		@0x10003510 	
1 	nspr4.dll 	PR_SetPollableEvent 	nsprpub/pr/src/io/prpolevt.c:232
2 	xul.dll 	nsSocketTransportService::OnDispatchedEvent 	netwerk/base/src/nsSocketTransportService2.cpp:597
3 	xul.dll 	nsThread::Dispatch 	xpcom/threads/nsThread.cpp:424
4 	xul.dll 	nsTimerImpl::PostTimerEvent 	xpcom/threads/nsTimerImpl.cpp:558
5 	xul.dll 	TimerThread::Run 	xpcom/threads/TimerThread.cpp:300
6 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:625
7 	xul.dll 	nsThreadStartupEvent::`vector deleting destructor' 	
8 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:273
9 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
10 		@0x13 	
11 	msvcr80.dll 	_getptd_noexit 	f:\\sp\\vctools\\crt_bld\\self_x86\\crt\\src\\tidtable.c:633
12 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
13 	msvcr80.dll 	_callthreadstartex 	f:\\sp\\vctools\\crt_bld\\self_x86\\crt\\src\\threadex.c:348
14 	msvcr80.dll 	_threadstartex 	f:\\sp\\vctools\\crt_bld\\self_x86\\crt\\src\\threadex.c:326
15 	kernel32.dll 	BaseThreadStart

Updated

6 years ago
Depends on: 716345

Updated

6 years ago
Crash Signature: [@ PR_SetPollableEvent ] → [@ PR_SetPollableEvent ] [@ PR_SetPollableEvent | nsSocketTransportService::OnDispatchedEvent(nsIThreadInternal*)]
Summary: Firefox crash @ PR_SetPollableEvent → Firefox crash in nsSocketTransportService::OnDispatchedEvent @ PR_SetPollableEvent

Updated

2 years ago
Crash Signature: [@ PR_SetPollableEvent ] [@ PR_SetPollableEvent | nsSocketTransportService::OnDispatchedEvent(nsIThreadInternal*)] → [@ PR_SetPollableEvent ] [@ PR_SetPollableEvent | nsSocketTransportService::OnDispatchedEvent(nsIThreadInternal*)] [@ PR_SetPollableEvent | nsSocketTransportService::OnDispatchedEvent]
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 662330
You need to log in before you can comment on or make changes to this bug.