Language name for csb does not appear in the dictionaries list

RESOLVED DUPLICATE of bug 586085

Status

()

RESOLVED DUPLICATE of bug 586085
7 years ago
6 years ago

People

(Reporter: jurk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111206234556

Steps to reproduce:

I co-author Kashubian Spell Checker (add-on). In the past, for the add-on to correctly display in Firefox and Thunderbird, the dictionaries had to be named "Kashubian / Poland.dic" Since the csb locale was recently added (at least for Firefox), I would like to rely on Mozilla to properly match the name.


Actual results:

Kashubian Spell Checker (locale: csb) cannot pull correct name. The add-on's dictionary is named "csb-pl.dic" Since "csb" cannot be pulled, the add-on is listed as "   /Poland" as apposed to "Kashubian/Poland" under Firefox / Thunderbird's dictionaries.


Expected results:

The csb locale was recently added to Mozilla when l10n added support for Kashubian Firefox. 

Can someone verify if the csb locale is correctly identified?
Component: Add-on Validation → Spelling checker
Product: addons.mozilla.org → Core
QA Contact: add-on-validation → spelling-checker
Version: 0.9 → unspecified

Updated

7 years ago
Component: Spelling checker → Admin/Editor Tools
Product: Core → addons.mozilla.org
QA Contact: spelling-checker → admin-tools
I don't think this is an AMO bug...?  If it is, can you be specific about what URL you're looking at?
Component: Admin/Editor Tools → Add-ons Manager
Product: addons.mozilla.org → Toolkit
QA Contact: admin-tools → add-ons.manager
Maybe the AOM?
Localizations I think. Adding some likely candidates. I believe we just have to add csb to languageNames.properties
Component: Add-ons Manager → Internationalization
Product: Toolkit → Core
QA Contact: add-ons.manager → i18n
Summary: Locale csb cannot be verified → Language name for csb does not appear in the dictionaries list
(Reporter)

Comment 4

7 years ago
Created attachment 602452 [details]
Screenshot

Please, have a look at the attachment. The "csb-pl" portion of the dictionary name in the Kashubian spellchecker should resolve to "Kashubian/Poland" but "csb" portion is ignored so we end up with "   /Poland" instead (the PL portion resolves correctly).
Depends on: 730209
Status: UNCONFIRMED → NEW
Ever confirmed: true
An update:

The fix for bug 730209 made it so that the language portion would no longer be empty. However, until bug 716321 is fixed, the raw language subtag ('csb') would be displayed instead.

I note that the current version of the Kashubian (Poland) spellchecker works around this problem by naming the dictionary files 'Kashubian' instead of 'csb' or 'csb-PL'. Normally, this would be frowned upon, because it prevents localization. However, since the 'csb' language subtag is not made available to localizers in the 'en-US' locale, I won't make a big deal about it. (Do note, though, that if any other locale decided to take it upon themselves to localize the 'csb' language subtag, this workaround would prevent that localized language name from being displayed.)

For the record, once bug 716321 is fixed, I believe the dictionary files should be renamed 'csb'. There is no need to include the 'PL' region subtag, as that makes the dictionary more specific than it needs to be. (Kashubian is not spoken in large numbers outside of Poland.)
Depends on: 716321
Depends on: 586085
(Reporter)

Comment 6

6 years ago
Thanks. As soon as the fix is applied, I will immediately make the correction.
This will be handled in bug 586085, so I'm marking this as a duplicate.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 586085
No longer depends on: 716321
No longer depends on: 586085
You need to log in before you can comment on or make changes to this bug.