Closed Bug 586085 Opened 10 years ago Closed 8 years ago

Add localizable language names to Firefox: Hawaiian, Hiligaynon, Kashubian

Categories

(Core :: Internationalization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: kscanne, Assigned: GPHemsley)

References

Details

(Whiteboard: [bcp47])

Attachments

(1 file, 1 obsolete file)

I've created spell checking addons for these three languages, but the languages aren't among those in toolkit/chrome/global/languageNames.properties.

As a consequence, the names do not appear correctly in the right-click context menu when attempting to spellcheck.   The reviewers at AMO won't move these out of the sandbox until this is resolved.  They suggested renaming the files to "Hawaiian.dic", etc. but I'd prefer that they be localizable like all the other languages.

ISO 639-3 codes:
haw: Hawaiian
hil: Hiligaynon
csb: Kashubian
http://www.sil.org/iso639-3/documentation.asp?id=haw and friends show that there's no ISO 639-1 locale code for the three, which I'd prefer. Details on the languages can be found at http://www.ethnologue.com/show_language.asp?code=haw and friends.

I recall that there was a bug about getting full coverage for iso 639-3, but I can't find it right now. I recall commenting there that I'm not in favor of forcing all locales to cover all of it, and I would have preferred to go for a solution of having the full list in content, and just an optional opportunity in locale to explicitly overload.
There are more than 7500 languages in ISO 639-3.   Speaking as a localizer I second the sentiment that we shouldn't be required to localize all 7500!    

I'm happy as long as all languages with active localization teams or spell-checking add-ons are present in the list.   This number is unlikely to exceed 200 anytime in the next, say, 5 years.
Thanks to philor, I realized that we have two bcp47 bugs, and bug 356038 is actually the one that's talking about full iso 639-3 support.
Wikipedia's article for Lojban mentions that a Firefox add-on to make Lojban popup dictionary was proposed. It might be worthwhile to add "Lojban [jbo]" to our Preferred Languages list too.
Kashubian (csb) localization is 85% finished. I would appreacite any help of how to submit our translation (from Narro) to make it available for Firefox 4 release etc.
Jurk, Kashubian localizations are off topic for this bug. For taking new locales, most of our process documentation is on https://wiki.mozilla.org/L10n:Localization_Process, technical docs are on https://developer.mozilla.org/en/Create_a_new_localization. The closest bug to what you're looking for is an old attempt documented in bug 359500. But going through the process from scratch sounds like what you're looking for.
I've gotten a ping from a friend in the Hawaiian language community on this issue.  In addition to the spell checker (which was my original motivation), they'd like to be able to add Hawaiian as an Accept-Language in the Options->Content window.  Doing so would allow google.com and other sites to default to the language.
Kevin,

We have since created another bug (Jan 11) and are still waiting:

https://bugzilla.mozilla.org/show_bug.cgi?id=627680

If you know who can move this forward, let me know. We've been patiently waiting for:

1. The registration of the Kashubian localization 
2. Final review/approval/release of the Kashubian language version of Firefox 4.

Let me know.
Aloha. I'm probably the person Kevin is referring to regarding Hawaiian. I petitioned the ISO committee for 639-1 about 10 years ago, and they refused to issue  such a code for Hawaiian, saying that a 639-3 was sufficient.
Mahalo Keola.  Axel, is there any legwork I can do on your behalf to make this happen?  I could try to create a patch for the three languages in the bug, for example.  Or if you're serious about trying to include a broader collection of ISO 639-3 codes instead of adding them piecemeal, I can look into that too.
Assignee: nobody → smontagu
Component: General → Internationalization
Depends on: bcp47
OS: Mac OS X → All
Product: Firefox → Core
QA Contact: general → i18n
Hardware: x86 → All
Whiteboard: [bcp47]
Version: unspecified → Trunk
Depends on: 666662
Duplicate of this bug: 684335
Depends on: 716321
No longer depends on: 666662
No longer depends on: bcp47
Blocks: 709930
For simplicity, creating patch for these 3 locales: Kashubian [csb], Hawaiian [haw], and Hiligaynon [hil].
Assignee: smontagu → gphemsley
Status: NEW → ASSIGNED
Attachment #658106 - Flags: review?(l10n)
Attachment #658106 - Flags: review?(jfkthame)
Duplicate of this bug: 709930
Comment on attachment 658106 [details] [diff] [review]
Add support for Kashubian [csb], Hawaiian [haw], and Hiligaynon [hil]

Review of attachment 658106 [details] [diff] [review]:
-----------------------------------------------------------------

7 million speakers, yikes. who would have thought.

TBH, I think this is also a spellchecker bug waiting to be filed, the add-on should come with a description we can use in the UI without toolkit changes.
Attachment #658106 - Flags: review?(l10n) → review+
Attachment #658106 - Flags: review?(jfkthame) → review?(smontagu)
Comment on attachment 658106 [details] [diff] [review]
Add support for Kashubian [csb], Hawaiian [haw], and Hiligaynon [hil]

Review of attachment 658106 [details] [diff] [review]:
-----------------------------------------------------------------

You need to patch langGroups.properties as well
Include langGroups:

csb = x-central-euro
haw = x-unicode
hil = x-western

(Despite being Latin-based, Hawaiian has a lot of diacritics that don't appear to be in any ISO 8859 encoding.)
Attachment #658106 - Attachment is obsolete: true
Attachment #658106 - Flags: review?(smontagu)
Attachment #660896 - Flags: review?(smontagu)
Attachment #660896 - Flags: review?(jfkthame)
Attachment #660896 - Flags: review?(smontagu) → review+
See bug 716321 comment 14 for checkin information.
Keywords: checkin-needed
Attachment #660896 - Flags: review?(jfkthame)
https://hg.mozilla.org/mozilla-central/rev/3c34aaab407a
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
x-central-euro does not contain all Kashubian letters. 

Unicode should be used instead.
No longer blocks: 709930
No longer depends on: 716321
Target Milestone: mozilla18 → ---
Blocks: 792575
(In reply to Jurk from comment #20)
> x-central-euro does not contain all Kashubian letters. 
> 
> Unicode should be used instead.

Filed bug 792575 for that.
Blocks: 793249
(In reply to Gordon P. Hemsley [:gphemsley] from comment #21)
> (In reply to Jurk from comment #20)
> > x-central-euro does not contain all Kashubian letters. 
> > 
> > Unicode should be used instead.
> 
> Filed bug 792575 for that.

That bug has changed scope, and it was determined that the x-central-euro langGroup is fine for Kashubian.

It was, however, decided that x-unicode is too extreme for Hawaiian, so bug 793249 was opened to change it to x-western.

(LangGroups are merely groups that share font formatting properties; they are not directly tied to the encodings they suggest.)
No longer blocks: 792575
See Also: → 1428712
You need to log in before you can comment on or make changes to this bug.