"None" is not a useful message when browserID verification fails

RESOLVED FIXED in 6.3.9

Status

addons.mozilla.org Graveyard
Public Pages
P3
normal
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: krupa, Assigned: ashort)

Tracking

unspecified
6.3.9

Details

(Reporter)

Description

6 years ago
When  browserID verification fails, we show user message which says "None". Let us show something useful and informative.
Assignee: nobody → ashort
Priority: -- → P3
Blocks: 710074
No longer blocks: 690899
Duplicate of this bug: 711236
Target Milestone: --- → 6.3.9
(Assignee)

Comment 2

6 years ago
This is reproducible in the case where `backend.verify()` on line 315 of apps/users/view.py returns None.
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.