Last Comment Bug 710345 - Upgrade pywebsocket to v606 (support final WS spec)
: Upgrade pywebsocket to v606 (support final WS spec)
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: WebSockets (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: Jason Duell [:jduell] (needinfo me)
:
Mentors:
Depends on:
Blocks: 666349
  Show dependency treegraph
 
Reported: 2011-12-13 12:29 PST by Jason Duell [:jduell] (needinfo me)
Modified: 2011-12-20 03:07 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
part1: Google pywebsocket v553->606 changes (72.53 KB, patch)
2011-12-13 12:42 PST, Jason Duell [:jduell] (needinfo me)
mcmanus: review+
Details | Diff | Splinter Review
part2: Mozilla-specific changes (8.17 KB, patch)
2011-12-13 12:53 PST, Jason Duell [:jduell] (needinfo me)
mcmanus: review+
Details | Diff | Splinter Review

Description Jason Duell [:jduell] (needinfo me) 2011-12-13 12:29:59 PST
v606 supports protocol v17, and Sec-WebSocket-Version: 13, which we need.

Splitting into two patches: google's changes, and tweaks I made to get it to work for us.
Comment 1 Jason Duell [:jduell] (needinfo me) 2011-12-13 12:42:09 PST
Created attachment 581378 [details] [diff] [review]
part1: Google pywebsocket v553->606 changes

So this sits on top of the pywebsocket patch (not yet landed) for bug 689006.

I've split this out from changes I made as I think it needs minimal review, given that it's already reviewed and in production @ google.
Comment 2 Jason Duell [:jduell] (needinfo me) 2011-12-13 12:53:25 PST
Created attachment 581383 [details] [diff] [review]
part2: Mozilla-specific changes

test_websocket.html test-15 needed to be disabled: see comments. It's not a bug in our code, just that pywebsocket doesn't seem to allow us to emulate the server closing the TCP socket w/o sending a WS CLOSE any more. (if you think we need that test to work, let's open a separate bug for it--don't want to hold back progress for a minor test coverage issue).

test-16 fails if run standalone--fixed.

change runtests.py to use --allow-handlers-outside-root-dir so we don't have to patch pywebsocket code for that any more.
Comment 3 Patrick McManus [:mcmanus] 2011-12-14 08:26:39 PST
Comment on attachment 581383 [details] [diff] [review]
part2: Mozilla-specific changes

file a separate low priority bug about creating test coverage for the disabled test-15.

r=mcmanus
Comment 4 Jason Duell [:jduell] (needinfo me) 2011-12-14 19:50:58 PST
Thanks.

Filed bug 710954 for test-15.
Comment 5 Jason Duell [:jduell] (needinfo me) 2011-12-20 03:06:37 PST
https://hg.mozilla.org/mozilla-central/rev/225f854f8ff1
Comment 6 Jason Duell [:jduell] (needinfo me) 2011-12-20 03:07:08 PST
Also

https://hg.mozilla.org/mozilla-central/rev/ccb71819f0c2

Note You need to log in before you can comment on or make changes to this bug.