Last Comment Bug 710392 - exclude about: pages from top sites on about:home
: exclude about: pages from top sites on about:home
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: Firefox 12
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
Mentors:
: 709550 712889 715249 (view as bug list)
Depends on: 716089
Blocks: 716623
  Show dependency treegraph
 
Reported: 2011-12-13 14:00 PST by Brad Lassey [:blassey] (use needinfo?)
Modified: 2012-01-20 10:52 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified
11+


Attachments
patch (6.06 KB, patch)
2012-01-04 21:37 PST, Brad Lassey [:blassey] (use needinfo?)
lucasr.at.mozilla: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Brad Lassey [:blassey] (use needinfo?) 2011-12-13 14:00:34 PST

    
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-16 12:41:27 PST
*** Bug 709550 has been marked as a duplicate of this bug. ***
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-22 06:15:48 PST
*** Bug 712889 has been marked as a duplicate of this bug. ***
Comment 3 Tim Maks van den Broek [:mad_maks] 2012-01-04 10:24:06 PST
Ok this bug is a dup of the one i filed but what is happening with it?

-is it not consider as a bug? and we live with it
-is it a bug, who is going to work on it
Comment 4 Aaron Train [:aaronmt] 2012-01-04 11:42:00 PST
*** Bug 715249 has been marked as a duplicate of this bug. ***
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2012-01-04 21:37:40 PST
Created attachment 585974 [details] [diff] [review]
patch
Comment 6 Lucas Rocha (:lucasr) 2012-01-05 02:45:21 PST
Comment on attachment 585974 [details] [diff] [review]
patch

Review of attachment 585974 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good but shouldn't we simply avoid recording visits to about: pages in history DB altogether? For instance, I think we shouldn't show about: pages in the history tab either. Also, we don't want stock browser to have list about: pages as they're Fennec-specific. I'm giving a r- until a good reason is given to keep about: records on DB.
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-05 05:42:29 PST
Desktop Firefox and XUL Fennec do not record about:* to history. However, you can bookmark an about:* page and it then will appear in the awesomebar results.

We could do the same thing in Native Fennec, but a bookmarked about:* page would likely show up in the "Top Sites" list, unless we filter. Even about:home
Comment 8 Brad Lassey [:blassey] (use needinfo?) 2012-01-05 07:33:19 PST
Comment on attachment 585974 [details] [diff] [review]
patch

(In reply to Lucas Rocha (:lucasr) from comment #6)
> Comment on attachment 585974 [details] [diff] [review]
> patch
> 
> Review of attachment 585974 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Looks good but shouldn't we simply avoid recording visits to about: pages in
> history DB altogether? For instance, I think we shouldn't show about: pages
> in the history tab either. Also, we don't want stock browser to have list
> about: pages as they're Fennec-specific. I'm giving a r- until a good reason
> is given to keep about: records on DB.

1) That doesn't fix the issue for anyone that's used fennec up to now and has about:pages in their history
2) about: pages should at least show up in the Awesomebar if their bookmarked
3) given that we only show 3 or 4 top sites, I think we should exclude them from the top sites section regardess of whether they're in history or not

So, I suggest we need this whether we stop putting about pages in history or not
Comment 9 Lucas Rocha (:lucasr) 2012-01-05 07:35:28 PST
Comment on attachment 585974 [details] [diff] [review]
patch

Review of attachment 585974 [details] [diff] [review]:
-----------------------------------------------------------------

Ok, please make sure there's a bug report about not storing about: pages in history.
Comment 10 Steffen Wilberg 2012-01-05 09:15:04 PST
This hides all about pages, right? Changing summary accordingly.
Comment 11 Madhava Enros [:madhava] 2012-01-05 13:01:16 PST
About:home is really the only about: page that should be excluded on about:home. I think about: pages should be in history, too.
Comment 12 Marco Bonardo [::mak] 2012-01-06 04:41:09 PST
https://hg.mozilla.org/mozilla-central/rev/4f11bea71a4a
Comment 13 Aaron Train [:aaronmt] 2012-01-06 06:17:48 PST
Samsung Nexus S (Android 4.0.3)
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120106 Firefox/12.0a1 Fennec/12.0a1
20120106043323
http://hg.mozilla.org/mozilla-central/rev/af6501ede378

Aurora nom?
Comment 14 Brad Lassey [:blassey] (use needinfo?) 2012-01-10 11:08:20 PST
Comment on attachment 585974 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
"top sites" section about:home can be completely occupied by about: pages, such as about:home
Testing completed (on m-c, etc.): 
on m-c
Risk to taking this patch (and alternatives if risky):
pretty risk-free
Comment 15 Alex Keybl [:akeybl] 2012-01-11 13:23:29 PST
Comment on attachment 585974 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora.
Comment 16 Brad Lassey [:blassey] (use needinfo?) 2012-01-20 10:52:38 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/984285420b33

Note You need to log in before you can comment on or make changes to this bug.