Last Comment Bug 710750 - ESC key should exit Tilt (page inspector 3D)
: ESC key should exit Tilt (page inspector 3D)
Status: VERIFIED FIXED
[tilt][fixed-in-fx-team][qa+][qa!:11]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: Firefox 12
Assigned To: Victor Porof [:vporof][:vp]
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on:
Blocks: 711341
  Show dependency treegraph
 
Reported: 2011-12-14 09:28 PST by Kevin Dangoor
Modified: 2012-02-24 06:00 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
verified


Attachments
v1 (4.49 KB, patch)
2011-12-15 04:43 PST, Victor Porof [:vporof][:vp]
rcampbell: review+
Details | Diff | Splinter Review
v2 (4.46 KB, patch)
2011-12-19 09:54 PST, Victor Porof [:vporof][:vp]
rcampbell: review+
christian: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Kevin Dangoor 2011-12-14 09:28:05 PST
Right now, pressing <esc> does nothing when you are in 3D mode of the page inspector. It would be nice if <esc> would exit 3D mode.
Comment 1 Victor Porof [:vporof][:vp] 2011-12-15 04:43:57 PST
Created attachment 581933 [details] [diff] [review]
v1
Comment 2 Rob Campbell [:rc] (:robcee) 2011-12-16 07:47:30 PST
Comment on attachment 581933 [details] [diff] [review]
v1

looks good!
Comment 3 Victor Porof [:vporof][:vp] 2011-12-19 09:54:08 PST
Created attachment 582864 [details] [diff] [review]
v2

Because bug 700199 recently changed how EventUtils.sendKey works.
Comment 4 Rob Campbell [:rc] (:robcee) 2011-12-20 08:54:18 PST
Comment on attachment 582864 [details] [diff] [review]
v2

like
Comment 5 Rob Campbell [:rc] (:robcee) 2011-12-20 09:02:25 PST
https://hg.mozilla.org/integration/fx-team/rev/c2cb5d6b8cb9
Comment 6 Rob Campbell [:rc] (:robcee) 2011-12-20 09:03:17 PST
Comment on attachment 582864 [details] [diff] [review]
v2

would like to get this into aurora. Adds an ESC keyboard shortcut to exit tilt and return to the regular view in the Inspector. minimal impact. maximal enjoyment.
Comment 7 Ed Morley [:emorley] 2011-12-21 11:58:22 PST
https://hg.mozilla.org/mozilla-central/rev/c2cb5d6b8cb9
Comment 8 christian 2011-12-21 15:54:40 PST
Comment on attachment 582864 [details] [diff] [review]
v2

[triage comment]
Approved for aurora. "minimal impact. maximal enjoyment". Simple fix to a new feature.
Comment 9 Rob Campbell [:rc] (:robcee) 2012-01-04 06:31:46 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/3b8cb000c284
Comment 10 Trif Andrei-Alin[:AlinT] 2012-01-17 23:56:24 PST
QA Verified on Firefox 11 & Firefox 12
Comment 11 Simona B [:simonab ] 2012-02-24 06:00:12 PST
Verified using Firefox 11 beta 4 on Windows 7, Ubuntu 11.10 and Mac OS X 10.6 - pressing Esc key exits Tilt.

Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0

Note You need to log in before you can comment on or make changes to this bug.