Last Comment Bug 711341 - Tilt should give focus back to Highlighter when closed
: Tilt should give focus back to Highlighter when closed
Status: VERIFIED FIXED
[tilt][fixed-in-fx-team][qa+][qa!:11]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Victor Porof [:vporof][:vp]
:
: Patrick Brosset <:pbro>
Mentors:
Depends on: 710750
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-16 00:14 PST by Victor Porof [:vporof][:vp]
Modified: 2012-02-23 10:18 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
v1 (2.27 KB, patch)
2011-12-16 00:31 PST, Victor Porof [:vporof][:vp]
rcampbell: review+
christian: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Victor Porof [:vporof][:vp] 2011-12-16 00:14:08 PST

    
Comment 1 Victor Porof [:vporof][:vp] 2011-12-16 00:31:38 PST
Created attachment 582194 [details] [diff] [review]
v1
Comment 2 Victor Porof [:vporof][:vp] 2011-12-16 00:33:21 PST
Depends on bug 710750 because of an "instance" param added to onTiltOpen in head.js for testing to work properly.
Comment 3 Rob Campbell [:rc] (:robcee) 2011-12-20 09:05:34 PST
https://hg.mozilla.org/integration/fx-team/rev/9aa0f5842d75
Comment 4 Rob Campbell [:rc] (:robcee) 2011-12-20 09:07:40 PST
Comment on attachment 582194 [details] [diff] [review]
v1

This restores focus on the content window when tilt is closed. Leaves you where you were before you made everything go all tilty! Would be nice in aurora...
Comment 5 Ed Morley [:emorley] 2011-12-21 11:57:50 PST
https://hg.mozilla.org/mozilla-central/rev/9aa0f5842d75
Comment 6 christian 2011-12-21 15:57:16 PST
Comment on attachment 582194 [details] [diff] [review]
v1

[triage comment]
Approved for aurora. While this probably wouldn't meet our criteria at the end of a cycle ("nice to have", feature works fine without, etc). We are early in the cycle and the risk looks low to take this for what will likely be a banner feature.
Comment 7 Rob Campbell [:rc] (:robcee) 2012-01-04 06:32:10 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/f089c471e778
Comment 8 Trif Andrei-Alin[:AlinT] 2012-01-18 00:04:08 PST
Verified on Firefox 11 & Firefox 12
Comment 9 Simona B [:simonab ] 2012-02-23 08:54:43 PST
Verified using Firefox 11 Beta 4 on Win XP, Mac OS X 10.6 and Ubuntu 11.10 - focus is on the Highlighter after Tilt is closed.

Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0

Note You need to log in before you can comment on or make changes to this bug.