Last Comment Bug 710835 - Form autocomplete popup list flickers as you type
: Form autocomplete popup list flickers as you type
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
: P2 normal (vote)
: Firefox 12
Assigned To: :Margaret Leibovic
:
Mentors:
: 711181 714082 715564 (view as bug list)
Depends on:
Blocks: 695444
  Show dependency treegraph
 
Reported: 2011-12-14 12:13 PST by :Margaret Leibovic
Modified: 2012-01-16 22:32 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
11+


Attachments
patch (2.25 KB, patch)
2012-01-10 16:29 PST, :Margaret Leibovic
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description :Margaret Leibovic 2011-12-14 12:13:34 PST
Follow-up from bug 695444 comment 14.
Comment 1 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-12-15 11:54:14 PST
Steps to reproduce:
- Go to http://people.mozilla.org/~mwargers/tests/autocomplete_forms/textinput_form.html
- Tap on the input, type 'abc' and submit the form
- Tap on the input again
- Now type 'b' a couple of times

Notice how the form autocomplete popup keeps appearing and disappearing on every keystroke.
Comment 2 :Margaret Leibovic 2012-01-06 15:03:38 PST
*** Bug 715564 has been marked as a duplicate of this bug. ***
Comment 3 :Margaret Leibovic 2012-01-06 15:04:50 PST
*** Bug 711181 has been marked as a duplicate of this bug. ***
Comment 4 :Margaret Leibovic 2012-01-06 15:09:21 PST
Changing this to a P2, since I duped bug 711181 to it and that's a P2.

I feel like one patch should fix all the popup flicker problems, but I still have to look into exactly what we need to change.
Comment 5 :Margaret Leibovic 2012-01-10 16:29:15 PST
Created attachment 587533 [details] [diff] [review]
patch

I'm not quite sure why we decided to listen for composition* events instead of input events when we first implemented this - my guess is that input events weren't working properly at the time. In any case, this avoids lots of the problems we were having with compositionupdate events (wrong data strings, firing at the wrong times, etc).

The only issue I see with this is that the popup with suggestions doesn't appear when you first focus the text box, but that's not working right now anyway - we can fix that in another bug.
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-10 20:24:19 PST
Comment on attachment 587533 [details] [diff] [review]
patch

Glad to see this is working
Comment 8 Ed Morley [:emorley] 2012-01-11 18:08:14 PST
https://hg.mozilla.org/mozilla-central/rev/ad341c2f7cdf
Comment 9 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-01-12 07:32:18 PST
Thanks, I verified this is indeed fixed in today's native Fennec build. Also bug 711181 is indeed fixed now, so it was indeed a duplicate.
Comment 10 :Margaret Leibovic 2012-01-12 09:32:17 PST
Comment on attachment 587533 [details] [diff] [review]
patch

[Approval Request Comment]
User impact if declined: form autocomplete popups will continue to have lots of problems
Testing completed (on m-c, etc.): verified on Nightly
Risk to taking this patch (and alternatives if risky): input events could have problems again, but they're in a much better state than composition events right now
Comment 11 Alex Keybl [:akeybl] 2012-01-12 22:23:11 PST
Comment on attachment 587533 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approving for Aurora.
Comment 12 :Margaret Leibovic 2012-01-16 11:28:37 PST
*** Bug 714082 has been marked as a duplicate of this bug. ***
Comment 13 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-16 22:32:24 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/286038d5a00d

Note You need to log in before you can comment on or make changes to this bug.