Attachment filename is appended with a number when "Edit Draft" the second time

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: ji, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
****observed with win32, linux and mac 03/06 mtrunk builds**********

When clicking on "Edit Draft" for a draft with an attachment on the first time,
the attachment filename comes up correctly on the mail compose window. But when
you do it on the second time, the attachment filename will be appended with a
number, which reflects the time you edit the draft.


Steps to reproduce:
1. Launch Mail.
2. Compose a mail and attach a file to the mail.
3. Select File | Save as | Draft to save the mail as a draft.
4. Go to the draft folder, select the mail you just saved and  click on " Edit
Draft...", the mail compose window will come up, the attachment filename shows
correctly.
5. Close the compose window and select the same draft and click on "Edit
Draft..." again. This time on the mail compose window, the attachment filename
will be appended with "-2"

Comment 1

18 years ago
What happens when you send it? Does the message with the wrong attachment names
send the attachments correctly or does it send nothing?
(Reporter)

Comment 2

18 years ago
When the draft is sent out, the attachment is sent with a wrong filename.

Comment 3

18 years ago
Can the receiver download the attachment or because the attachment name is wrong
is the attachment not sent at all?  The bug is much higher priority to me if the
attachment isn't sent or isn't downloadable because the name is incorrect.
(Reporter)

Comment 4

18 years ago
Even the filename is wrong, it still can be opened.
With this build, the downdload is not working. (Open the file on the browser 
first and select File | save as doesn't bring up the file dialog window. It's a 
different bug. It has this problem even with a correct attachment filename)

Comment 5

17 years ago
See the bug on build 2001070921, Linux.
I saw not only "-1", "-2" added to the file name, but also "--1", "--2".
The index is added not only when I click "Edit Draft" button, but also when I
use <Ctrl-E> combination (Edit As New) in other folders.
I the name change is global, so if I have change with "-2" for one message, I'll
have the same change for all the files with this name when I try compose other
messages.

Updated

17 years ago
QA Contact: esther → trix

Comment 6

16 years ago
*** Bug 86399 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
i'm unable to reproduce this (as well as the dup)
QA Contact: trix → stephend
Product: Browser → Seamonkey

Comment 8

14 years ago
WFM with current builds. So I resolving this bug. Feel free to reopen if you can
reproduce the problem with current builds.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
OS: Linux → All
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.