Last Comment Bug 711071 - Fix velocity calculation
: Fix velocity calculation
Status: RESOLVED FIXED
[mtd][inbound]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 normal (vote)
: Firefox 12
Assigned To: Wesley Johnston (:wesj)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-15 07:54 PST by Lawrence Mandel [:lmandel] (use needinfo)
Modified: 2016-07-29 14:21 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
+


Attachments
catlog while being unable to scroll (24.36 KB, text/plain)
2011-12-15 07:54 PST, Lawrence Mandel [:lmandel] (use needinfo)
no flags Details
Patch (1.01 KB, patch)
2011-12-19 17:27 PST, Wesley Johnston (:wesj)
no flags Details | Diff | Splinter Review
Patch (871 bytes, patch)
2012-01-24 12:41 PST, Wesley Johnston (:wesj)
pwalton: review+
doug.turner: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Lawrence Mandel [:lmandel] (use needinfo) 2011-12-15 07:54:15 PST
Created attachment 581967 [details]
catlog while being unable to scroll

Build:20111214
Device: Samsung Galaxy S II

Occasionally when I open the browser to a page I cannot scroll at all. Firefox does not respond to any panning/scrolling touch events. Note that at this time I can still click buttons, links, and the awesome bar. I can also zoom. Restarting the browser allows me to pan/scroll again.

Unfortunately I have not been able to determine a reliable path to reproduce the issue. I was able to catch a catlog with some interesting messages that I hope will shed some light on the source of this issue.

12-15 10:36:30.900: I/GeckoSoftwareLayerClient(10290): Adjusting viewport
12-15 10:36:31.130: I/InputReader(2715): dispatchTouch::touch event's action is 0, pending(waiting finished signal)=0
12-15 10:36:31.140: I/InputDispatcher(2715): Delivering touch to current input target: action: 0, channel '40767260 org.mozilla.fennec/org.mozilla.fennec.App (server)'
12-15 10:36:31.145: E/lights(2715): write_int: path /sys/devices/virtual/misc/melfas_touchkey/brightness, value 1
12-15 10:36:31.145: I/PowerManagerService(2715): Ulight 3->7|0
12-15 10:36:31.145: D/PowerManagerService(2715): setLightBrightness : mButtonLight : 69
12-15 10:36:31.175: E/GeckoPanZoomController(10290): Received impossible touch move while in NOTHING
12-15 10:36:31.185: E/GeckoPanZoomController(10290): Received impossible touch move while in NOTHING
12-15 10:36:31.230: E/GeckoPanZoomController(10290): Received impossible touch move while in NOTHING
...
Comment 1 Aaron Train [:aaronmt] 2011-12-15 08:00:30 PST
recent regression? dupe of bug 710694?
Comment 2 Lawrence Mandel [:lmandel] (use needinfo) 2011-12-15 08:17:53 PST
The video in bug 710694 shows different behaviour than what I'm seeing here. There is no jumping or random resizing as shown. For me, the page loads fine but is stuck from a pan/scroll position. I can zoom in or out as expected but still can't move the page up/down/left/right.
Comment 3 Wesley Johnston (:wesj) 2011-12-19 17:27:49 PST
Created attachment 583032 [details] [diff] [review]
Patch

This fixes some issues with the fling controller. I'm also sometimes seeing finishAnimation called over and over and over. Apparently we're killing the timertask but not cancelling? Still digging on that bit.

Looking into this because I'm running into issues while working on the touchevents stuff, and want to see if there faults with those patches or something else.
Comment 4 Doug Turner (:dougt) 2012-01-23 14:56:04 PST
is your patch needed?  has this problem been addressed already.
Comment 5 Wesley Johnston (:wesj) 2012-01-24 12:41:42 PST
Created attachment 591226 [details] [diff] [review]
Patch

Not fixed yet.
Comment 6 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-24 13:00:04 PST
(In reply to Wesley Johnston (:wesj) from comment #3)
> This fixes some issues with the fling controller. I'm also sometimes seeing
> finishAnimation called over and over and over. Apparently we're killing the
> timertask but not cancelling? Still digging on that bit.

If you figure out anything to do with this, let me know. I have bug 713011 which is tracking this issue.
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-26 14:28:31 PST
Changed bug into something appropriate for the patch. Bug 713011 will handle the panning issue
Comment 8 Patrick Walton (:pcwalton) 2012-01-26 14:29:38 PST
Comment on attachment 591226 [details] [diff] [review]
Patch

Review of attachment 591226 [details] [diff] [review]:
-----------------------------------------------------------------

r=me
Comment 10 Wesley Johnston (:wesj) 2012-01-28 09:28:00 PST
Comment on attachment 591226 [details] [diff] [review]
Patch

Nom for aurora. Fixes a bug in how we calculate the velocity. Can lead to issues with panning. Mobile only.
Comment 11 Joe Drew (not getting mail) 2012-01-28 18:50:04 PST
https://hg.mozilla.org/mozilla-central/rev/f8282085e225
Comment 12 Brad Lassey [:blassey] (use needinfo?) 2012-01-30 11:43:16 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/02093039f454

Note You need to log in before you can comment on or make changes to this bug.