Closed Bug 711177 Opened 9 years ago Closed 9 years ago

Form autocomplete popup doesn't appear on tap of input

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(blocking-fennec1.0 -)

VERIFIED FIXED
Firefox 13
Tracking Status
blocking-fennec1.0 --- -

People

(Reporter: martijn.martijn, Assigned: Margaret)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

Steps to reproduce:
- Go to http://people.mozilla.org/~mwargers/tests/autocomplete_forms/textinput_form.html
- Tap on the input, type 'abc' and submit the form
- Tap on the input again

Expected result:
A form autocomplete popup should appear with the entry 'abc' inside it.

Actual result:
No form autocomplete popup
Keywords: testcase
OS: Windows 7 → Android
Hardware: x86 → ARM
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 711096
This looks like a different issue than the one we ended up discussing in bug 711096. That bug was about showing identical matching results, and this bug is about showing results for an empty input box when you tap on it.

I think we should consider showing results for an empty input box to give the user the opportunity to avoid using the keyboard.
Assignee: nobody → margaret.leibovic
Status: RESOLVED → REOPENED
Keywords: uiwanted
Resolution: DUPLICATE → ---
blocking-fennec1.0: --- → ?
Yes - I think I agree with Margaret in Comment 2.
Keywords: uiwanted
Attached patch patchSplinter Review
This patch prioritizes a validation message over an autocomplete suggestion in the focus case, which is the opposite of how we handle the input case. I did this because that's what XUL fennec does. Also, I think that makes sense, since the form validation message will only be available if an invalid form was submitted, and in that case, the user is probably like "Hm, why was my input wrong?" more than "Hey, give me some suggestions!"
Attachment #603445 - Flags: review?(lucasr.at.mozilla)
Comment on attachment 603445 [details] [diff] [review]
patch

Review of attachment 603445 [details] [diff] [review]:
-----------------------------------------------------------------

Good.
Attachment #603445 - Flags: review?(lucasr.at.mozilla) → review+
blocking-fennec1.0: ? → -
https://hg.mozilla.org/mozilla-central/rev/5a19bd82cb53
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 13
Verified fixed on:
-build: Firefox for Android 21.0a1 (2013-02-15)
-device: Samsung Galaxy Tab 2 7.0
-OS: Android 4.0.4
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.