Last Comment Bug 711184 - make sure we don't do any work creating about:home if we're not showing about:home
: make sure we don't do any work creating about:home if we're not showing about...
Status: RESOLVED FIXED
[inbound]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P2 normal (vote)
: ---
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-15 11:09 PST by Brad Lassey [:blassey] (use needinfo?)
Modified: 2012-01-09 10:15 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (6.38 KB, patch)
2011-12-16 09:00 PST, Brad Lassey [:blassey] (use needinfo?)
no flags Details | Diff | Splinter Review
patch (3.58 KB, patch)
2011-12-16 13:22 PST, Brad Lassey [:blassey] (use needinfo?)
doug.turner: review+
Details | Diff | Splinter Review
patch (9.15 KB, patch)
2011-12-19 21:09 PST, Brad Lassey [:blassey] (use needinfo?)
doug.turner: review+
Details | Diff | Splinter Review

Description Brad Lassey [:blassey] (use needinfo?) 2011-12-15 11:09:33 PST
the OS constructs the about:home content even if we're not showing it, I want to confirm that we're not hitting the history and bookmark DBs when we're not showing about:home because we're launched with a URI
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2011-12-16 09:00:53 PST
Created attachment 582291 [details] [diff] [review]
patch

this makes sure we don't hit the DBs if we're not showing about:home
Comment 2 Brad Lassey [:blassey] (use needinfo?) 2011-12-16 13:22:21 PST
Created attachment 582372 [details] [diff] [review]
patch
Comment 3 Doug Turner (:dougt) 2011-12-16 14:19:32 PST
Comment on attachment 582372 [details] [diff] [review]
patch

Review of attachment 582372 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/AboutHomeContent.java
@@ +169,2 @@
>          GeckoAppShell.getHandler().post(new Runnable() {
>              public void run() {

Is the spacing off between inflater.* and GeckoAppShell

::: mobile/android/base/GeckoApp.java
@@ +977,4 @@
>  
>          public void run() {
>              mAutoCompletePopup.hide();
> +            if (mAboutHomeContent == null && mShow) {

Do you need the mShow test here?
Comment 4 Brad Lassey [:blassey] (use needinfo?) 2011-12-16 16:05:12 PST
> >  
> >          public void run() {
> >              mAutoCompletePopup.hide();
> > +            if (mAboutHomeContent == null && mShow) {
> 
> Do you need the mShow test here?
That's the part that keeps us from constructing the about:home view until its going to be shown
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2011-12-16 17:03:56 PST
pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/434e5060c706
Comment 6 Matt Brubeck (:mbrubeck) 2011-12-17 09:30:34 PST
https://hg.mozilla.org/mozilla-central/rev/434e5060c706
Comment 7 Doug Turner (:dougt) 2011-12-17 22:47:25 PST
brad, this crashes on ICS.  I backed it out.

https://hg.mozilla.org/mozilla-central/rev/a5e63e00db27
Comment 8 Doug Turner (:dougt) 2011-12-17 22:51:13 PST
ine 185 mTopSitesGrid is null.  not sure if onFinishInflate is being called.  only ics.
Comment 9 Brad Lassey [:blassey] (use needinfo?) 2011-12-19 21:09:55 PST
Created attachment 583059 [details] [diff] [review]
patch
Comment 10 Brad Lassey [:blassey] (use needinfo?) 2011-12-19 21:22:03 PST
pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/3f050eb4f8ac
Comment 11 Brad Lassey [:blassey] (use needinfo?) 2011-12-19 22:57:35 PST
backed out https://hg.mozilla.org/integration/mozilla-inbound/rev/6d281a8799fb
Comment 12 Brad Lassey [:blassey] (use needinfo?) 2011-12-19 23:55:57 PST
turns out there are two gecko_app.xml's now. Fixed and re-landed on inbound https://hg.mozilla.org/integration/mozilla-inbound/rev/feaccb6a4c35
Comment 13 Ed Morley [:emorley] 2011-12-20 05:16:37 PST
https://hg.mozilla.org/mozilla-central/rev/feaccb6a4c35

Note You need to log in before you can comment on or make changes to this bug.