Last Comment Bug 711216 - Form autocomplete popup doesn't disappear when input gets out of view after pinch zoom
: Form autocomplete popup doesn't disappear when input gets out of view after p...
Status: VERIFIED FIXED
: testcase
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 11 Branch
: ARM Android
: P2 normal (vote)
: Firefox 12
Assigned To: :Margaret Leibovic
:
Mentors:
: 711218 711219 (view as bug list)
Depends on:
Blocks: 695444
  Show dependency treegraph
 
Reported: 2011-12-15 12:50 PST by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2012-01-09 16:34 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified
11+


Attachments
patch (1.69 KB, patch)
2011-12-21 17:07 PST, :Margaret Leibovic
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2011-12-15 12:50:05 PST
- Go to http://people.mozilla.org/~mwargers/tests/autocomplete_forms/textinput_form.html
- Tap on the input, type 'abc' and submit the form
- Tap on the input again
- Type 'a' -> form autocomplete popup appears with 'abc' in it
- Now pinch zoom the page in such a way that the input gets out of view

Expected result:
- Form autocomplete popup should disappear when the input gets out of view

Actual result:
- Form autocomplete popup stays visible
Comment 1 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-12-16 09:03:07 PST
*** Bug 711218 has been marked as a duplicate of this bug. ***
Comment 2 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-12-16 09:03:21 PST
*** Bug 711219 has been marked as a duplicate of this bug. ***
Comment 3 :Margaret Leibovic 2011-12-21 17:07:20 PST
Created attachment 583684 [details] [diff] [review]
patch

This just hides the popup whenever we zoom. Should we try to re-show it after zooming?
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-26 07:34:36 PST
(In reply to Margaret Leibovic [:margaret] from comment #3)

> Should we try to re-show it after zooming?

I don't think we should.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-26 07:36:14 PST
Comment on attachment 583684 [details] [diff] [review]
patch

We should have this cleanup on aurora
Comment 6 Alex Keybl [:akeybl] 2011-12-26 11:33:45 PST
Comment on attachment 583684 [details] [diff] [review]
patch

[Triage Comment]
Let's land this on Aurora after we take it on m-c. Shortcutting normal process here because of where we are in the cycle and the straightforwardness of the patch.
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-26 22:38:04 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/c7416f66e61f

will land on aurora once this hits m-c
Comment 8 Matt Brubeck (:mbrubeck) 2011-12-27 11:16:45 PST
https://hg.mozilla.org/mozilla-central/rev/c7416f66e61f
Comment 9 Carla Nadastean 2011-12-29 09:04:30 PST
Verified with:
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20111229 Firefox/12.0a1
Fennec/12.0a1
HTC Desire Z (Android 2.3)

Form autocomplete popup disappears when the input gets out of view.

Note You need to log in before you can comment on or make changes to this bug.