Last Comment Bug 711658 - Intergrated gpu no longer used on Nightly
: Intergrated gpu no longer used on Nightly
Status: RESOLVED FIXED
[qa?]
: regression
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla12
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
Depends on:
Blocks: 696376 715802
  Show dependency treegraph
 
Reported: 2011-12-16 16:18 PST by Jeff Muizelaar [:jrmuizel]
Modified: 2012-02-22 11:36 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
Do TriggerQuirks earlier (9.86 KB, patch)
2011-12-19 10:22 PST, Jeff Muizelaar [:jrmuizel]
bgirard: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Jeff Muizelaar [:jrmuizel] 2011-12-16 16:18:26 PST
Looks like it was caused by 696376
Comment 1 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-12-16 20:09:18 PST
Jeff, this needs to sort of block Fx11, right?
Comment 2 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2011-12-19 07:16:44 PST
Jeff, was this caused by
https://hg.mozilla.org/mozilla-central/rev/c9a74f4ee1f7

That is really strange, but most things about 696376 are. Can you confirm that that was the patch that broke it?
Comment 3 Jeff Muizelaar [:jrmuizel] 2011-12-19 10:22:24 PST
Created attachment 582874 [details] [diff] [review]
Do TriggerQuirks earlier

This moves the copy of NS_CompareVersions into the header to make things work.
Comment 4 Benoit Girard (:BenWa) 2011-12-20 10:24:16 PST
Comment on attachment 582874 [details] [diff] [review]
Do TriggerQuirks earlier

Review of attachment 582874 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Comment 5 Alex Keybl [:akeybl] 2011-12-27 07:43:14 PST
Please land on m-c and nominate for Aurora 11 approval. Thanks!
Comment 6 Marco Bonardo [::mak] 2012-01-05 08:42:14 PST
https://hg.mozilla.org/mozilla-central/rev/2325e88b6026
Comment 7 Jeff Muizelaar [:jrmuizel] 2012-01-05 14:41:46 PST
Comment on attachment 582874 [details] [diff] [review]
Do TriggerQuirks earlier

[Approval Request Comment]
Regression caused by (bug #): 696376
User impact if declined: We end up always using the discrete GPU (i.e. worse battery life)
Testing completed (on m-c, etc.): none yet
Risk to taking this patch (and alternatives if risky): Low, this just calls an independent function earlier.
Comment 8 Alex Keybl [:akeybl] 2012-01-06 12:37:31 PST
Comment on attachment 582874 [details] [diff] [review]
Do TriggerQuirks earlier

[Triage Comment]
Approved for Aurora given where we are in the cycle, the risk assessment of this code change, and the impact to a user's battery life.
Comment 9 Jeff Muizelaar [:jrmuizel] 2012-02-13 12:33:22 PST
This actually made it into Aurora but I forgot to include a link:
https://hg.mozilla.org/mozilla-beta/rev/2325e88b6026
Comment 10 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-02-22 11:36:03 PST
Is there anything QA can do to verify this bug?

Note You need to log in before you can comment on or make changes to this bug.