messages with zip, doc, or xls attachments won't send

VERIFIED DUPLICATE of bug 70928

Status

MailNews Core
Composition
--
major
VERIFIED DUPLICATE of bug 70928
17 years ago
9 years ago

People

(Reporter: K Chayka, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
win32 build 2001030605 and every other build I've tried for the past couple of
weeks.

Cannot send mail with attachments other than text, html or image (gif/jpg, maybe
png) files. Have been unsuccessful sending zip, MS Word, or MS Excel files. The
main mail window gets stuck with status "Sending message" and the send never
completes. New messages can be sent while mail is in this state, providing there
are either no attachments, or attachments are only text, html or image files.
Only once did a zip file send, but I could not make it happen a second time.
Sending multiple text, html or image (and combinations of) seems OK on this
particular build. And in case it makes any difference, I have no added helper
applications - just the text/internal that comes with mozilla.

This makes mozilla mail *unusable*.

My setup/test, using dial-up account, no proxy:
1. Start Profile Manager: add a new profile (I did this to ensure starting with
all default pref values, but the behavior is the same regardless of prefs.)
2. Added my pop mail account
3. Change pop account settings: uncheck all Server Settings boxes (I did this to
make sure biff wasn't a factor, but the behavior is the same when biff is on.)
4. Change outgoing smtp server settings: Use SSL = never (I did this to make
sure PSM wasn't a factor, but the behavior is the same when the default "When
available" is set.)
5. Shut down mozilla. Start mozilla -mail (I did this to make sure I got a clean
start with new pref settings).
6. Click Get Msg: logon to the mail server.
7. Click New Msg: to myself, attached a jpg using the file picker.
8. Click Send: it sends and the "Copy complete" message shows in the mail status
bar.
9. Click New Msg: to myself, attach a zip file using the file picker.
10. Click Send: compose window disappears, mail status bar shows "Sending
message..." but it never sends - waited about 5 minutes, which was more than ample.
11. Disconnect: get the "Sending of message failed" alert.
12. Click OK: the compose window reappears. Message can be saved to Drafts at
this point.

Below is from message source of failed send (nothing unusual that I can see):
From - Wed Mar 07 08:10:34 2001
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
FCC: mailbox://kchayka@mail.citilink.com/Sent
Message-ID: <3AA6415A.30401@citi-link.com>
Date: Wed, 07 Mar 2001 08:10:34 -0600
From: kchayka <kchayka@citi-link.com>
X-Mozilla-Draft-Info: internal/draft; vcard=0; receipt=0; uuencode=0
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; 0.8.1) Gecko/20010306
X-Accept-Language: en
MIME-Version: 1.0
To: kchayka <kchayka@citi-link.com>
Subject: send zip
Content-Type: multipart/mixed;
 boundary="------------030504010107010105030606"

This is a multi-part message in MIME format.
--------------030504010107010105030606
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit

send a zip file

--------------030504010107010105030606
Content-Type: application/octet-stream;
 name="test-2.ZIP"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
 filename="test-2.ZIP"

UEsDBAoAAAAAAGVdTypGZdgpsj8AALI/AAAQACQAZm9udF9wcmVmcy0yLmdpZgoAIAAAAAAA
[snip to end of file contents - was a zipped gif file, size 17kb]
EAAAAAAAAAAAACAAAAAAAAAAZm9udF9wcmVmcy0yLmdpZlBLBQYAAAAAAQABAD4AAAAEQAAA
AAA=
--------------030504010107010105030606--


Message source from successful jpg send:
From - Wed Mar 07 08:03:55 2001
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
Message-ID: <3AA63FC8.7050905@citi-link.com>
Date: Wed, 07 Mar 2001 08:03:52 -0600
From: kchayka <kchayka@citi-link.com>
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; 0.8.1) Gecko/20010306
X-Accept-Language: en
MIME-Version: 1.0
To: kchayka <kchayka@citi-link.com>
Subject: send jpg
Content-Type: multipart/mixed;
 boundary="------------090400040700050603020009"

This is a multi-part message in MIME format.
--------------090400040700050603020009
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit

send 1 jpg

--------------090400040700050603020009
Content-Type: image/jpeg;
 name="test-2.jpg"
Content-Transfer-Encoding: base64
Content-Disposition: inline;
 filename="test-2.jpg"

/9j/4AAQSkZJRgABAAEAyADIAAD//gAfTEVBRCBUZWNobm9sb2dpZXMgSW5jLiBWMS4wMQD/
[snip to end of file contents, file size 3kb]
0qkAEY+YE5p69N3ehiGM3y9B+VI4GPujrTQEiqMdKjHU0kAgY4PSm7z7UwP/2Q==
--------------090400040700050603020009--

Comment 1

17 years ago
I just sent a message with a .doc attached, today.

K Chayka, don't file *all* your bugs as blockers. Blockers are only used for
bugs which disables extremely important features like: news reading, using
bookmark manager, opening Mozilla etc.

Downgrading to major, while still not confirming as this WFM.
Severity: blocker → major

Comment 2

17 years ago
Maybe this is connected to bug 70862 or bug 70928?

Comment 3

17 years ago
I've been working on both of these bugs with varada and yes, this is a dup of
70928.  I think 70862 will also be marked a dup of 70928.  

*** This bug has been marked as a duplicate of 70928 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

17 years ago
To Håkan B. Waara: just so you know, I've filed a number of other bugs and this
is the only one I've ever considered a blocker, so I don't file *all* my bugs
this way. As I said, this bug makes mail *unusable* for me, due to the volume of
attachments I need to send for business reasons. I guess I thought that was the
criteria.

Marking it blocker got somebody's attention, didn't it? :)
And bug 70928 is priortized as "normal", which is way wrong. Can it *please* get
a higher priority?

Comment 5

17 years ago
K Chayka, the bug this is marked a duplicate of was changed from all to only on
linux & mac because of a fix that seemed to fix windows platform.  Since this is
reported on Windows, can you confirm this doesn't happen to you with a build
after 3-8-01, then I will verify it.

Comment 6

17 years ago
I will verify this as a dup, please reopen if you are still seeing this on
windows builds after 3/8/01. Thanks
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

17 years ago
This was apparently caused by the 8kb attachment size problem and was fixed with
the 3/9 build socket patch. Haven't had a problem with it since then.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.