Highlight and delete unified trash doesn't work

RESOLVED DUPLICATE of bug 556749

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 556749
7 years ago
6 years ago

People

(Reporter: Loren Klingman, Unassigned)

Tracking

8 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 582642 [details]
screen.jpg Delete pressed between the left and right screenshot

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0.1) Gecko/20100101 Firefox/8.0.1
Build ID: 20111120135848

Steps to reproduce:

Open thunderbird in safemode
Open unified trash folder (I have 8 mail accounts - 7 POP3, 1 IMAP) (viewing in threaded mode)
Sort by date
(I have Total 711 listed at the bottom)
Highlight all messages before x date (Selected 45)
Press Delete


Actual results:

Total now 699  (all selected messages were not deleted)

The same occurs when using the threaded view.


Expected results:

Total now 666 (sorry for the number, that is just the way things came out....)  (all selected messages deleted)
(Reporter)

Comment 1

7 years ago
Created attachment 582643 [details]
Example to show account names (lo is one account lx is another)

Example to show account names (lo is one account lx is another)
This example only involved 2 of my 8 accounts.
As you can see only the messages from the lo account were deleted.
lx is IMAP and lo POP3, but in testing with messages from 2 POP3 accounts, they behave the same way.  Only the messages that are on the same account as the top selected message are actually deleted.
(Reporter)

Comment 2

7 years ago
I think 
https://bugzilla.mozilla.org/show_bug.cgi?id=618595#c3
Tried to address this, but failed in describing it well enough for testing.

Comment 3

6 years ago
bienvenu - backend?
Component: Mail Window Front End → Folder and Message Lists
QA Contact: front-end → folders-message-lists

Comment 4

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #3)
> bienvenu - backend?

I can't tell, since I don't know what's going on. Is there anything new on the error console after this happens?
(Reporter)

Comment 5

6 years ago
I'm happy to check if you can tell me how to open the error console.

Comment 6

6 years ago
Tools | error console
(Reporter)

Comment 7

6 years ago
No, nothing new there even in all view.

Comment 8

6 years ago
so, I think this will be duplicate of bug 556749
(Reporter)

Comment 9

6 years ago
The issue certainly looks to be the same.  Hopefully my screenshots will be of use to that bug thread.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 556749
You need to log in before you can comment on or make changes to this bug.