Last Comment Bug 711970 - Use openUnsharedDatabase in localStorage SQLite
: Use openUnsharedDatabase in localStorage SQLite
Status: RESOLVED FIXED
[Snappy:P1]
: perf
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla12
Assigned To: Vladan Djeric (:vladan)
:
Mentors:
Depends on:
Blocks: 704933 711972 714964
  Show dependency treegraph
 
Reported: 2011-12-19 06:42 PST by Marco Bonardo [::mak]
Modified: 2012-01-10 18:49 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Open DOM storage DB as unshared (1.99 KB, patch)
2011-12-19 13:43 PST, Vladan Djeric (:vladan)
no flags Details | Diff | Splinter Review
Open DOM storage DB as unshared (1.42 KB, patch)
2011-12-19 13:51 PST, Vladan Djeric (:vladan)
honzab.moz: review+
mak77: feedback+
Details | Diff | Splinter Review

Description Marco Bonardo [::mak] 2011-12-19 06:42:39 PST
This call is cheaper for our case, since SQLite doesn't have to check the cache before using it.
Comment 1 Marco Bonardo [::mak] 2011-12-19 06:43:58 PST
this is basically part of vladan's patch in bug 704933, so assigning to him, I'll later attach the partial patch.
Comment 2 Vladan Djeric (:vladan) 2011-12-19 13:43:49 PST
Created attachment 582940 [details] [diff] [review]
Open DOM storage DB as unshared

2-line patch from bug 704933
Comment 3 Vladan Djeric (:vladan) 2011-12-19 13:51:46 PST
Created attachment 582947 [details] [diff] [review]
Open DOM storage DB as unshared
Comment 4 Marco Bonardo [::mak] 2011-12-19 14:33:06 PST
Comment on attachment 582947 [details] [diff] [review]
Open DOM storage DB as unshared

Review of attachment 582947 [details] [diff] [review]:
-----------------------------------------------------------------

I'll leave feedback on this patch, and let Honza give review, so he is aware of the change and I'm sure we are on the same boat (he'll likely have to review my next patches on top of this) :)
Btw, there should be no risk involved in doing this change.
Comment 5 Honza Bambas (:mayhemer) 2012-01-09 10:45:55 PST
Comment on attachment 582947 [details] [diff] [review]
Open DOM storage DB as unshared

Review of attachment 582947 [details] [diff] [review]:
-----------------------------------------------------------------

r=honzab
Comment 7 Ed Morley [:emorley] 2012-01-10 18:49:20 PST
https://hg.mozilla.org/mozilla-central/rev/afa049904ea6

Note You need to log in before you can comment on or make changes to this bug.