Last Comment Bug 712006 - Remove the Binder class from localStorage
: Remove the Binder class from localStorage
Status: RESOLVED FIXED
: perf
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla12
Assigned To: Marco Bonardo [::mak] (Away 6-20 Aug)
:
Mentors:
Depends on: 711972
Blocks: 704933 714964
  Show dependency treegraph
 
Reported: 2011-12-19 08:24 PST by Marco Bonardo [::mak] (Away 6-20 Aug)
Modified: 2012-01-11 18:02 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1.0 (13.14 KB, patch)
2011-12-20 04:54 PST, Marco Bonardo [::mak] (Away 6-20 Aug)
honzab.moz: review+
Details | Diff | Splinter Review

Description Marco Bonardo [::mak] (Away 6-20 Aug) 2011-12-19 08:24:23 PST
That's useless overhead afaict, BindingParamsArray is useful when you have to bind mutiple params in a single execution, that is never the case here.
I have the patch ready.
Comment 1 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-12-20 04:54:13 PST
Created attachment 583116 [details] [diff] [review]
patch v1.0

As I said, I don't think this class adds anything useful, apart some overhead.
Comment 2 Honza Bambas (:mayhemer) 2011-12-21 03:35:36 PST
The binder was there because there was not the API you are using now.

I'll review after the new year.
Comment 3 Honza Bambas (:mayhemer) 2012-01-09 11:20:40 PST
Comment on attachment 583116 [details] [diff] [review]
patch v1.0

Review of attachment 583116 [details] [diff] [review]:
-----------------------------------------------------------------

r=honzab

Thanks.
Comment 4 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-01-11 02:49:27 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/bf9bc81cfc0c
Comment 5 Ed Morley [:emorley] 2012-01-11 18:02:12 PST
https://hg.mozilla.org/mozilla-central/rev/bf9bc81cfc0c

Note You need to log in before you can comment on or make changes to this bug.