Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Clean up jstypes.h

RESOLVED FIXED in mozilla12

Status

()

Core
JavaScript Engine
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Waldo, Assigned: Ms2ger)

Tracking

unspecified
mozilla12
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Bug 711672 comment 7:
> Feel free to file as followup or ignore, but: it would be nice if jstypes.h
> were mv'd to js/public.  mfbt/Types.h will conflict if you just name it
> js/public/Types.h.  Looking at the remaining content of jstypes.h, there
> isn't too much, and what there is isn't types.  Perhaps it can just be
> injected into js/public/Utility.h?  Also there are a lot remaining goofballs
> to be moved into LegacyIntTypes.h (JSWord, JSUWord, JSPtrDiff, JSSize,
> JSInt, JSIntn...).
(Assignee)

Comment 1

6 years ago
JSSize/JSPtrdiff/JSUptrdiff are completely unused, and can probably be removed.
Depends on: 714728
(Assignee)

Updated

6 years ago
Depends on: 714052
(Assignee)

Comment 2

6 years ago
Created attachment 588377 [details] [diff] [review]
Patch v1
Assignee: general → Ms2ger
Status: NEW → ASSIGNED
Attachment #588377 - Flags: review?(n.nethercote)
Attachment #588377 - Flags: review?(n.nethercote) → review+
(Assignee)

Comment 3

6 years ago
https://hg.mozilla.org/mozilla-central/rev/d7984d345c24
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla12
(Assignee)

Updated

6 years ago
Depends on: 725548
(Assignee)

Updated

5 years ago
Duplicate of this bug: 465638
You need to log in before you can comment on or make changes to this bug.