Closed Bug 71204 Opened 19 years ago Closed 18 years ago

Downloading is broken

Categories

(SeaMonkey :: UI Design, defect, blocker)

PowerPC
Mac System 9.x
defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: paulkchen, Assigned: paulkchen)

References

()

Details

(Keywords: regression)

Using 2001-03-07-08 mac mozilla build, click on the "Mac" build link at the top
of mozillazine (today has links to March 6 builds). When the save/use app dialog
comes up, notice how "OK" and "Cancel" buttons don't have text (minor issue).
Once you click OK, the dialog claims 9 secs have elapsed, and the progress meter
is empty. It appears like nothing is happening, i.e. the progress dialog never
updates. On the desktop, the file is about ~2.7MB in size. After a little bit of
time, the dialog goes away, but you still have an imcomplete download. Nice,
very nice.
Adding regression and dogfood keywords. Note, I used the installer bits if that
makes a difference. Mozilla 0.8 bits, 2001021502, downloading works.
This is partly described in bug 71178.  I am also se3eing intermittanf failure
to download on mac (along with the UI problems noted in bug 71178).  I can
usually get the download to complete the second attmept.  Addign a few folks who
might be able to help.

Additional information:
This happend with HTTP downloads as well (so doed 71178 for me).  
Steps to Reproduce:
1. Click link to start download
http://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk/MacMozillaInstaller.sea.bin
2. With "Open Using |Stuffit Expander| radio button selected hit the "OK" button.

Results:  
Download starts but does not complete, stuffit is never called to unpack the
download since it never finished.  

One other daya point. I seem to have better results if I let it do most of the
download in thge background before hitting OK on the dialog.  If I wait for five
or 6 seconds before hitting OK I almost never see the failure but if I hit OK
quickly I often see the failure.

Intermittent download failure is known (bug 53429) and may be related to bug 
70408.
*** Bug 72201 has been marked as a duplicate of this bug. ***
Is this still happening in a current build?  Looks like most of the bugs
referenced here have been fixed, so maybe this problem went away (what's the
emoticon for crossed fingers? :-)
I am no longer seeing download failures on Mac.  I tried a handfull of different
file types and sizes with the 03/27 builds and did not see any failures.  

pchen, are you still having problems here? any one else?
roughly every 1 out of 6 download attempts [at least on the mac --need to check
on other platforms] fails for me with this result: the Saving File [download
progress] dialog appears to have completed, but the file in the target directory
is incomplete [eg, only 1.2M of the 11.9M MacMozillaFullInstaller is there]. is
that the same as this bug? [was using 2001.03.29.08 comm bits]
i see this as well.
Keywords: nsbeta1
see also bug 85514, where the download progress dialog fails in the middle of
downloading --the progress meter just stops and sits there and sits and sits...
looks like simon has a potential fix there, too.
think this is fixed. any other oppinions?
->XPApps
Assignee: asa → pchen
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh
marking wfm. reopen if it ain't.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
mass verification of WorksForMe bugs: to find all bugspam pertaining to this,
set your search string to "IfItWorksForSlappyTheSquirrelThenItWFM".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. that it's still a problem with ***recent trunk builds*** on the all
appropriate platform[s]

b. provide clear steps to reproduce (unless a good test case is already in the
bug report), making sure it pertains to the original problem (avoid morphing as
much as possible :)
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.