Last Comment Bug 712159 - Line between window title bar and toolbar in standalone window
: Line between window title bar and toolbar in standalone window
Status: RESOLVED FIXED
needs tabsontop
:
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: Thunderbird 11.0
Assigned To: Andreas Nilsson (:andreasn)
:
Mentors:
Depends on: tb-tabsontop
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-19 15:49 PST by Andreas Nilsson (:andreasn)
Modified: 2011-12-21 13:15 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot of the issue (27.53 KB, image/png)
2011-12-19 15:49 PST, Andreas Nilsson (:andreasn)
no flags Details
patch fixing the issue (1.33 KB, patch)
2011-12-20 08:40 PST, Andreas Nilsson (:andreasn)
bwinton: review+
bwinton: ui‑review+
Details | Diff | Review
screenshot of patch in action (230.86 KB, image/png)
2011-12-20 10:05 PST, Andreas Nilsson (:andreasn)
no flags Details

Description Andreas Nilsson (:andreasn) 2011-12-19 15:49:47 PST
Created attachment 582988 [details]
screenshot of the issue

I think this is restricted to the tabs on top patch (bug #644169)
There seems to be a line between the window title bar and the toolbar when you open a message in a new window.
Comment 1 Andreas Nilsson (:andreasn) 2011-12-19 18:29:12 PST
It seems that the only thing I can see differ between standalone window and and the 3pane window is the nodeName mail:messageWindow vs. mail:3pane.

I tried to select this with:
window[windowtype=mail:messageWindow] .mail-toolbox {
  -moz-appearance: toolbox;
}

The css parser did not enjoy that at all.
Then again, it's 3:30 in the morning, so I might be missing something. :)
Comment 2 Jim Porter (:squib) 2011-12-19 19:15:10 PST
I think you need quotes around "mail:messageWindow".
Comment 3 Andreas Nilsson (:andreasn) 2011-12-20 08:40:47 PST
Created attachment 583185 [details] [diff] [review]
patch fixing the issue

The bug is caused by the special toolbar styling we're doing to the main toolbar in 3pane. This patch special-cases the standalone window case.
Comment 4 Andreas Nilsson (:andreasn) 2011-12-20 10:05:50 PST
Created attachment 583209 [details]
screenshot of patch in action
Comment 5 Blake Winton (:bwinton) (:☕️) (PTO 'til London. Find me there for quick answers!) 2011-12-20 10:11:41 PST
Comment on attachment 583185 [details] [diff] [review]
patch fixing the issue

Review of attachment 583185 [details] [diff] [review]:
-----------------------------------------------------------------

Code looks good (modulo the notes below).  r=me.
And the screenshot you posted looks good, except that the lines are missing from the toolbars in the 3-pane, too…  So, uh, I'm not sure what to put for ui-r…

I'll say ui-r=me if the main window still has lines between the toolbars.

::: mail/themes/pinstripe/mail/primaryToolbar.css
@@ -133,4 +141,4 @@
> >    margin: 5px 4px 3px;
> >  }
> >  
> > -#tabbar-toolbar .toolbarbutton-1 {
> > +#tabbar-toolbar > .toolbarbutton-1 {

Is this change (and the previous one) needed to fix the bug, or is it just cleanup suggested by Sid?

@@ -139,4 +147,5 @@
> >    padding-top: 0;
> >    padding-bottom: 0;
> >  }
> >  
> > +

Could we remove this extra line?
Comment 6 Blake Winton (:bwinton) (:☕️) (PTO 'til London. Find me there for quick answers!) 2011-12-20 10:26:23 PST
Huh.  As Andreas pointed out on IRC, we don't have the lines between the toolbars in Windows or Linux, or in Firefox on OSX, so removing them here makes sense, too.

Given that, ui-r=me just the way it is.

Thanks,
Blake.
Comment 7 Mike Conley (:mconley) - (Away until June 29th) 2011-12-20 14:29:00 PST
Checked in to comm-central as http://hg.mozilla.org/comm-central/rev/0dd28e137266

Note You need to log in before you can comment on or make changes to this bug.