"Elapsed Time" is not displayed for the S0/S1 tests

RESOLVED INVALID

Status

()

Firefox for Android
General
--
blocker
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1) download http://people.mozilla.com/~nhirata/Perf/startup5.html 
2) adb push startup5.html /sdcard/download/
3) install build from : http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-central-android/1324041795/
4) adb shell am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App -d file://sdcard/download/startup5.html#1324063534673

Expected: Onload time displayed
Actual: error message "the URL is not valid and cannot be loaded."

Note:
Build 20111219; Samsung Nexus S; OS 2.3

http://www.youtube.com/watch?v=tXLBT8auV6k
Looking at the url the outcome of the url became : file:///sdcard/download

closing tabs, and clearing the application data, I am getting file:///download/startup5.html#1324063534673

The intent shows the proper download path in both cases:
Starting: Intent { act=android.intent.action.VIEW dat=file://sdcard/download/startup5.html#1324063534673 cmp=org.mozilla.fennec/.App }
Same root cause as bug 711855

You would probably see the same error in logcat too
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 711855
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I have also tried:
adb shell am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App -d file://mnt/sdcard/download/startup5.html#1324063534673

which I get 
Starting: Intent { act=android.intent.action.VIEW dat=file://mnt/sdcard/download/startup5.html#1324063534673 cmp=org.mozilla.fennec/.App }

and the url is mangled to file:///sdcard/download/startup5.html#1324063534673
(In reply to Naoki Hirata :nhirata from comment #4)
> I have also tried:
> adb shell am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App
> -d file://mnt/sdcard/download/startup5.html#1324063534673
> 
> which I get 
> Starting: Intent { act=android.intent.action.VIEW
> dat=file://mnt/sdcard/download/startup5.html#1324063534673
> cmp=org.mozilla.fennec/.App }
> 
> and the url is mangled to file:///sdcard/download/startup5.html#1324063534673

This is not mangled. file:/// is actually correct.
Created attachment 583302 [details]
logcat

Logcat.  It's not the mangled URL after all speaking to mfinkle.  There's some wierdness going on in logcat that I noticed, but I'm not 100 % sure if that's the issue.
I think we have two bugs here:
1. Throbber never stops
2. "Elapsed Time" is not displayed

#1 can be fixed right away by adding a | document.close(); | to startup5.html

Put it right after the document.write(...)

Not using the | document.close() | works on desktop because they use "NETWORK_STOP" to turn off the throbber and we use "DOCUMENT_STOP" - which never fires since the document is not closed. We plan on using NETWORK_ notifications too, so that will also fix the issue, in the longer term.

#2 could be a viewport issue. The page (startup5.html) is initialy, completely blank. Then we add a <span> to it onload. It could be a rendering issue. Reloading the page causes the <span> to become visible, but the "time" metric is bogus at that point.

CC'ing Kats and Chris for any viewport insights.
I should mention, in the latest nightlies I do not see "URL is not valid" anymore. Naoki, if you don't see it either, let's update the bug summary.
(In reply to Mark Finkle (:mfinkle) from comment #7)
> #2 could be a viewport issue. The page (startup5.html) is initialy,
> completely blank. Then we add a <span> to it onload. It could be a rendering
> issue. Reloading the page causes the <span> to become visible, but the
> "time" metric is bogus at that point.
> 
> CC'ing Kats and Chris for any viewport insights.

I don't think this is Fennec-specific. If I go to http://people.mozilla.com/~nhirata/Perf/startup5.html#0 in desktop Firefox 8.0.1 it does the same thing. I suspect sticking in the document.close() will fix that as well, as it should trigger a flush on the HTML stream and repaint the new stuff. IIRC the new behaviour is correct as per HTML5 parsing rules.
bug 712414 is in regards to the throbber not stopping.  It seems that mfinkle is already on that bug.

I do not notice the error message with these steps, I can reproduce it with steps that include going to the awesome page.  I changed the title of this bug and will report the other bug where I get the error message consistantly.
Summary: S0, S1 tests (onload local and twitter local) are showing the URL is not valid and cannot be loaded. → "Elapsed Time" is not displayed for the S0/S1 tests
using a setTimeout in onload() works around the problem.  I sent Naoki and updated version of his tests that use this approach so that testing can continue.
doing a document.close works too.

Marking INVALID.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WONTFIX
Does not work on the Galaxy S II that I have been running.  Handed off the Galaxy S II to Dougt.  Dougt tried to show this, and it did not show on the device.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.